Bug 103149 - The postinstall script breaks if older GConf2 package is installed
The postinstall script breaks if older GConf2 package is installed
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-panel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-27 01:26 EDT by Fulton Green
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-27 12:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fulton Green 2003-08-27 01:26:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When I installed the newer gnome-panel package, I received an error from
gconftool-2 saying that it didn't recognize the "--load" option.  This was
because I still had an older version of the GConf2 package, yet the postinstall
script was clearly expecting to use a newer gconftool-2 that would take the
"--load" option.

If the gnome-panel package had a dependency on the newer GConf2 package, I would
have known to dowload GConf2 then upgrade both packages simultaneously.

Version-Release number of selected component (if applicable):
2.3.6.2-4

How reproducible:
Always

Steps to Reproduce:
1. Install Severn.
2. Upgrade to latest gnome-panel in Raw Hide, but do NOT upgrade to latest GConf2.
    

Actual Results:  I got a nastygram from gconftool-2 saying it didn't recognize
the "--load" option.

Expected Results:  No nastygrams.

Additional info:
Comment 1 Alexander Larsson 2003-08-27 12:38:21 EDT
Fixed in 2.3.7-1

Note You need to log in before you can comment on or make changes to this bug.