Bug 1031844 - Remove components from the guide that are not supported by RHOS.
Remove components from the guide that are not supported by RHOS.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Configuration_Reference_Guide (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-11-18 19:28 EST by Summer Long
Modified: 2016-04-26 19:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 22:40:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Summer Long 2013-11-18 19:28:52 EST
Started 1/2 request Oct.17, add 3 on Nov.19:
The following has been sent out to the dev team, and various managers
1) Which of the following plugins should be mentioned for OpenStack Networking:
* BigSwitch
* Brocade
* Cisco
* Cloudbase HyperV
* Linux Bridge
* Mellonox
* Meta
* Modular Layer2 (flattype, vxlan, arista, l2, cisco, tailf ncs)
* MidoNet
* NEC
* Nicira NVP
* OpenVSwitch
* PlumGrid
* RYU

2) Which of the following volume drivers are ok to mention for OpenStack Block Storage?
* Ceph RADOS Block Device (RBD)
* Coraid AoE Driver Configuration
* EMC SMI-S iSCSI Driver
* GlusterFS Driver (note: = Red Hat Storage)
* HDS iSCSI Volume Driver
* HP 3PAR Fibre Channel and iSCSI Drivers
* HP / LeftHand SAN
* Huawei Storage Driver
* IBM GPFS Volume Driver
* IBM Storwize Family and SVC Volume Driver
* NetApp Unified Driver
* Nexenta Drivers
* NFS Driver
* SolidFire

Have now added the following to this list:
3) Can you confirm that only KVM is supported in the following list of hypervisors?
* KVM - Kernel-based Virtual Machine. The virtual disk formats that it supports it inherits from QEMU since it uses a modified QEMU program to launch the virtual machine. The supported formats include raw images, the qcow2, and VMware formats.
* LXC - Linux Containers (through libvirt), use to run Linux-based virtual machines.
* QEMU - Quick EMUlator, generally only used for development purposes.
* UML - User Mode Linux, generally only used for development purposes.
* VMWare vSphere 4.1 update 1 and newer, runs VMWare-based Linux and Windows images through a connection with a vCenter server or directly with an ESXi host.
* Xen - XenServer, Xen Cloud Platform (XCP), use to run Linux or Windows virtual machines. You must install the nova-compute service in a para-virtualized VM.
* PowerVM - Server virtualization with IBM PowerVM, use to run AIX, IBM i and Linux environments on IBM POWER technology.
* Hyper-V - Server virtualization with Microsoft's Hyper-V, use to run Windows, Linux, and FreeBSD virtual machines. Runs nova-compute natively on the Windows virtualization platform.
* Bare Metal - Not a hypervisor in the traditional sense, this driver provisions physical hardware through pluggable sub-drivers (for example, PXE for image deployment, and IPMI for power management).
* Dockeris an open-source engine which automates the deployment of >applications as highly portable, self-sufficient containers which are >independent of hardware, language, framework, packaging system and hosting >provider.
Comment 1 Summer Long 2013-11-18 19:33:35 EST
Also to remove will be info for: Fedora, Ubuntu, Debian, openSUSE and SLES.

Perry, I've assigned you this since it's a general inquiry. Let me know if I should direct to someone else.
thanks, Summer
Comment 5 Summer Long 2013-11-20 01:13:46 EST
Added note to both the volume driver and plugin sections.

Looks like Mellanox and PLUMgrid are supposed to be spelled correctly. (Both mlnx and plumgrid used in the table header appear to be the plugin name, pulled out automatically from code.)

All references to Nicira NVP changed to VMWare NSX (also code, per https://blueprints.launchpad.net/neutron/+spec/nicira-plugin-renaming)

To research config and put in new Embrane section: Raised https://bugzilla.redhat.com/show_bug.cgi?id=1032398

Couldn't see any instances of 'arista', 'tail-f', or 'cisco', apart from the code usage (did correct quite a few errors though).

Commented out both Hyper-V Plugin and Agent.

Reworked hypervisors section to only reflect KVM and RHEL references.

To research config and put in new Dell EqualLogic and Zadara sections: https://bugzilla.redhat.com/show_bug.cgi?id=1032404
Comment 6 Summer Long 2013-11-20 02:12:19 EST
Working through all Ubuntu/openSUSE/Fedora references.
-----------
Julie, I'm having trouble finding the RHEL counterpart to this Ubuntu reference: 
Q: How do I adjust the dimensions of the VNC window image in the OpenStack dashboard?
A: These values are hard-coded in a Django HTML template. To alter them, edit the _detail_vnc.html template file. The location of this file varies based on Linux distribution. On Ubuntu 12.04, the file is at /usr/share/pyshared/horizon/dashboards/nova/instances/templates/instances/_detail_vnc.html.
Modify the width and height parameters, as follows:
<iframe src="{{ vnc_url }}" width="720" height="430"></iframe>

Can you tell me where the RHEL template is kept? Couldn't find anything likely on a PackStack allinone installation.  thanks, Summer
Comment 7 Julie Pichon 2013-11-20 05:45:28 EST
Hi Summer,

I'm wondering where the original question comes from? It seems out of date on 2 points:

1. _detail_vnc.html was renamed to be more general during the 3.0 / Grizzly release cycle, and is now called _detail_console.html (as it applies to both VNC and SPICE).
2. During the Grizzly / 3.0 timeframe, a patch to dynamically resize the console window was added, and it was also backported to Folsom / 2.1 (2012.2.4 upstream). In my mind, this should negate the need for manually modifying the values (for instance the height and width are now set to 100% in that template, rather than hard-coded)
Comment 9 Summer Long 2013-11-22 01:46:36 EST
 Scrubbing for Ubuntu, apt-get, Xen, XenAPI, suse Linux, Fedora,  XenServer
 Also switched out documentation references.
   
   ch_config-overview.xml
        
   block-storage/section_volume-drivers.xml, added note about third-party drivers    
   block-storage/ceph-rbd-volume-driver.xml, moved author cite down to a link in a note       
   block-storage/drivers/emc-volume-driver.xml
   block-storage/drivers/hds-volume-driver.xml      
   block_storage/section_volume-drivers.xml
   block_storage/emc-volume-driver.xml
   block_storage/drivers/hp-lefthand-driver.xml
   
   ch_computeconfigure.xml       
   compute/section_compute-config-overview.xml  
   compute/section_compute-scheduler.xml           
   compute/section_compute-configure-migrations.xml             
   compute/section_compute-configure-ipv6.xml  
    compute/section_compute-hypervisors.xml, reworked to only reflect KVM as the option.
    compute/section_kvm.xml, reworked to only use RHEL references.
    compute/section_compute-configure-migrations.xml
   common/section_host_aggregates.xml
   common/section_compute-configure-vnc.xml --have asked Julie Pichon for help on this one.             
   common/section_compute-configure-vnc.xml
   common/section_fibrechannel.xml
   common/nova-baremetal.xml      
   local_settings.py/ removed last paragraph about ubuntu settings (couldn't just comment out)       
   common/section_dashboard-configure-http.xml
   common/section_dashboard-configure-https.xml
   common/section_compute-configure-vnc.xml
   common/section_kvm_enable.xml
   
   ch_networkingconfigure.xml
   networking/section_networking-adv-config.xml
   networking/section_networking-plugins.xml, added note about third-party plugins, updated refs from Nicira NVP to VMWare NSX, commented out Cloudbase Hyper-V Plugin and Agent. Quite a few edits on the Arista table.
   networking/section_networking-scenarios.xml
   networking/section_networking-config-identity.xml


   object-storage/section_object-features.xml, updated section on swift-python-s3, Pete Z. confirmed updated section was ok.

Will update with Julie's comments with review comments.
Comment 10 Julie Pichon 2013-11-22 04:44:26 EST
Hi Summer, thanks for the link, I had a look at the FAQ you pointed to + Chapter 4 for the dashboard. Here are a few comments as to how they relate to Havana / 4.0, to the best of my knowledge.

The copy of local_settings in 4.1.1 is old, I wonder if it's worthwhile mentioning the whole file when the answer only mentions OPENSTACK_HOST? New settings get added all the time.

If we want to keep the full copy for now, a recent sample is available at https://github.com/openstack/horizon/blob/stable/havana/openstack_dashboard/local/local_settings.py.example

4.2.1 and 4.2.2 - I'd make a note to indicate that these files must match the respective service's policy file, e.g. keystone_policy.json should be the same as /etc/keystone/policy.json.

4.2.2 - The first line reads "keystone-policy" instead of "nova_policy" (and as a nit in 4.2.1 it should be keystone_policy with an underscore)

I think the VNC window size adjustment in 3.3.5.1.5 and 4.1.3 can be removed for Havana / 4.0.
Comment 11 Summer Long 2013-11-26 00:58:54 EST
Merged up in git; ready for QA when a new version is on the test server.

Note You need to log in before you can comment on or make changes to this bug.