Bug 103185 - up2date can fail to restart after updating itself
Summary: up2date can fail to restart after updating itself
Status: CLOSED DUPLICATE of bug 104152
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-27 13:02 UTC by Michael Young
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2003-08-27 13:02:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
With up2date 3.9.14-2 updating itself to 3.9.15-2, the restart can fail with the
error
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
 
No interactive mode available
Please specify either -l, -u, --nox, or package names as command line arguments.

followed by the standard usage message. This is running up2date as an ordinary
user, ie. through console-helper. This also happened with an earlier upgrade,
though I don't remember the versions in that case.

Comment 1 Paul Nasrat 2003-08-27 15:01:03 UTC
I had an error running sudo up2date --nox up2date.  I got the following stack
trace, I'm assuming it's the same root cause.


error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
New Up2date available
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
error: db4 error(-30989) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page
not found
                                                                               
                    
Fetching Obsoletes list for channel: redhat-linux-severn-i386-9.0.93...
                                                                               
                    
Fetching Obsoletes list for channel: redhat-linux-severn-i386-9.0.93-updates...
                                                                               
                    
Fetching Obsoletes list for channel: fedora-9-i386-stable...
########################################
                                                                               
                    
Fetching Obsoletes list for channel: up2date-beta...
########################################
                                                                               
                    
Fetching Obsoletes list for channel: jpackage-1.5-generic-nonfree...
########################################
                                                                               
                    
Testing package set / solving RPM inter-dependencies...
########################################
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1148, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 755, in main
    updateUp2date=None)
  File "/usr/sbin/up2date", line 1014, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 64, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 134, in __dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 487, in dryRun
    rc)
up2date_client.up2dateErrors.ConflictError: RPM package conflict error.  The
message was:
Test install failed because of package conflicts:
package up2date-3.9.15-2 is already installed



Comment 2 Paul Nasrat 2003-08-27 15:06:46 UTC
I should add that up2date successfully updated itself despite my stack trace,
then again this could be an unrelated problem :)

Comment 3 Adrian Likins 2003-09-15 21:47:28 UTC
looks like the same as #104152

should be fixed in 3.9.27 or later

*** This bug has been marked as a duplicate of 104152 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:58:17 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.