Bug 104152 - non-fatal traceback (no observed symptoms)
non-fatal traceback (no observed symptoms)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 103185 104234 104244 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 11:27 EDT by Michael K. Johnson
Modified: 2007-04-18 12:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 14:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael K. Johnson 2003-09-10 11:27:12 EDT
Description of problem:
up2date --nosig
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1439, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence



I didn't see any error messages, so I don't know what might have
gone wrong.

Version-Release number of selected component (if applicable):
up2date-3.9.25-2

How reproducible:
Couldn't Reproduce
Comment 1 Adrian Likins 2003-09-10 14:22:45 EDT
Interesting. Not supposed to ever get to that block with an
empty list of skipped packages (which seems to be whats
happening).

Couple quick run thoughs doesnt show an easy duplication.
Any thing slightly odd of normal about that run? lots of
going backwards or something?
Comment 2 Michael K. Johnson 2003-09-10 14:46:02 EDT
No going backwards.  It's right after the bug reported in #104170, though.
I saw it again on the other severn system I'm running just now.
Comment 3 Adrian Likins 2003-09-11 00:21:54 EDT
It appears to be related to ##104170, which should be
fixed now. (more specifically, with the versions that
fail to restart and then attempt to jump to a somewhat
bogus saved state). The state info is bogus causing
the error show. Should not happen with the fix for
#104170. 

Let me know if you see it again with 3.9.26 or newer. 
Comment 4 Michael K. Johnson 2003-09-11 10:43:01 EDT
Aha, I finally paid enough attention to notice that this happens when a
"Packages Flagged to be Skipped" window pops up.  It has zero packages
listed in the window.

Incidentally, the last words on the screen, "select its checkbox", only show
the tops of the characters unless I resize that window larger.
Comment 5 Michael K. Johnson 2003-09-11 10:53:32 EDT
I should explicitly note that comment #4 is using 3.9.26-2
Comment 6 Chris Ricker 2003-09-11 13:54:42 EDT
*** Bug 104234 has been marked as a duplicate of this bug. ***
Comment 7 Chris Ricker 2003-09-11 13:58:16 EDT
Hmm, when I ran 3.9.26-2 w/o the rawhide and beta keys imported (just up2date,
w/o the --nosig) I got the empty skip list and the traceback

Once I imported the rawhide and beta keys, then ran again (again w/o the
--nosig), I didn't get the empty skip list, and I didn't get the traceback

Not sure if it's coincidental or not, though ;-)
Comment 8 Adrian Likins 2003-09-11 17:08:10 EDT
re comment #4, did the screen go directly to the
"Skipped Packages" or the more normal up2date?
Comment 9 Chris Ricker 2003-09-11 17:13:44 EDT
At least for me, it went first to empty Skipped Packages, then into the normal
up2date package selection
Comment 10 Dave Habben 2003-09-11 17:15:09 EDT
When it happend to me in bug 104234, it went directly to the "Skipped Packages"
list with nothing listed.
Comment 11 Adrian Likins 2003-09-11 17:28:21 EDT
okay, going directly to "skipped packages" (ie, no welcome screen, nothing)
is the behaviour when it restarts after updating itself (it caches the
already computed avaiable packages and such). 

So were this "skipped packages" screen errors after a bogus restart
with <= 3.9.25 (ie, a restart failed, then the next time up2date was
ran, you got the "skipped packages" directly and then the error) (option 1)
or did it all happen from one "up2date" invocation (up2date starts
up, updates itself, restarts correctly, goes to the skipped
package screen, and throws the traceback)? (option 2)

Or of course, None of the Above?

Note that versions prior to 3.9.26 when ran from a user account, will
fail to update/restart themselves properly. This leaves a bad state
file (causing the jump to empty packages). When up2date starts
up, it reads the state file, jumps ahead, then deletes the state
file (which is why you will only see this behaviour once).

Does that make sense? Any one seen this fail in a matter that
that doesnt seem to jive with?
Comment 12 Dave Habben 2003-09-11 17:33:40 EDT
(option 2) for me, and this was ran from the root account.
Comment 13 Chris Ricker 2003-09-11 17:35:25 EDT
Mine was option 1 as a non-root user -- ran older version, updated up2date,
tried to restart, failed, restarted manually from command line, went straight to
skipped and non-fatal traceback, subsequent runs from command linewere
traceback-free
Comment 14 Adrian Likins 2003-09-11 17:38:27 EDT
hmm, okay. The plot thickens. 

Now just to figure out why I can't reproduce this with 3.9.26

Thanks for the info
Comment 15 Michael K. Johnson 2003-09-12 08:10:38 EDT
I had exactly the same experience as kaboom.
Comment 16 Adrian Likins 2003-09-12 15:36:10 EDT
*** Bug 104244 has been marked as a duplicate of this bug. ***
Comment 17 Adrian Likins 2003-09-12 16:43:46 EDT
I belive this is fixed in 3.9.27. Or at list, after reproducing
the errors mentioned above with 3.9.26, the fixed in 3.9.27 seem
to make them go away for me.

Upgrading 3.9.26 to 3.9.27 should work fine, and then 3.9.27 should
be fine when it restarts. 
Comment 18 Adrian Likins 2003-09-15 17:47:32 EDT
*** Bug 103185 has been marked as a duplicate of this bug. ***
Comment 19 Dave Habben 2003-09-16 11:27:42 EDT
This looks like it's fixed. I could not duplicate it going from up2date-3.9.26-2
to up2date-3.9.28-2

Note You need to log in before you can comment on or make changes to this bug.