Bug 1031881 - sdCache should not report "looking for unfetched domain" as error
sdCache should not report "looking for unfetched domain" as error
Status: CLOSED DUPLICATE of bug 990070
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.2.0
All Linux
medium Severity medium
: ---
: 3.3.1
Assigned To: Vered Volansky
Aharon Canan
storage
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-18 23:31 EST by Marina
Modified: 2016-02-10 13:15 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 09:26:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 628283 None None None Never
oVirt gerrit 21597 None None None Never

  None (edit)
Description Marina 2013-11-18 23:31:25 EST
Description of problem:
This error is pointless and confuses the customers (sfdc#00978965, for instance).
It should be debug or info in this flow.
Or the flow is wrong.
Please see the details below:

Consider the log messages of DomainMonitorThread flow:
Thread-21::DEBUG::2013-11-18 22:37:22,793::domainMonitor::178::Storage.DomainMonitorThread::(_monitorDomain) Refreshing domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:37:22,794::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:37:22,794::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 534432b5-c19b-4181-9764-aee420a931f6
--
Thread-21::DEBUG::2013-11-18 22:42:24,017::domainMonitor::178::Storage.DomainMonitorThread::(_monitorDomain) Refreshing domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:42:24,018::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:42:24,018::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 534432b5-c19b-4181-9764-aee420a931f6
--
Thread-21::DEBUG::2013-11-18 22:47:25,353::domainMonitor::178::Storage.DomainMonitorThread::(_monitorDomain) Refreshing domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:47:25,354::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 534432b5-c19b-4181-9764-aee420a931f6
Thread-21::ERROR::2013-11-18 22:47:25,360::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 534432b5-c19b-4181-9764-aee420a931f6
--

Every 5 minutes (repo_stats_cache_refresh_timeout) monitorDomain would call 
  sdCache.manuallyRemoveDomain(self.sdUUID)
which would remove currently monitored domain from the cache.
Next, it will perform produce on the same domain, which will in turn go to sdCache and call: realProduce -> _findDomain.
In _findDomain it will try to access knownSDs list, but since this SD was just removed from the cache, it would not be present in this list.
This will print the first ERROR message:
     def _findDomain(self, sdUUID):
        try:
            findMethod = self.knownSDs[sdUUID]
        except KeyError:
            self.log.error("looking for unfetched domain %s", sdUUID)
            findMethod = self._findUnfetchedDomain                                                       
And then _findUnfetchedDomain will print the second error message:
    def _findUnfetchedDomain(self, sdUUID):
        import blockSD
        import localFsSD                                                                                 
        import nfsSD
                                                                                                         
        self.log.error("looking for domain %s", sdUUID)
--------------------------------------------------------------


Version-Release number of selected component (if applicable):
checked life on vdsm-4.10.2-27.0.el6ev.x86_64.
From 3.3 code(4.13.0-0.8.beta1.el6ev.x86_64), sdc code didn't change, so I believe the same would happen on 3.3.

How reproducible:
100%

Steps to Reproduce:
1. Get a running setup with Master Data Storage Domain.
2. Check /var/log/vdsm/vdsm/log for the error "looking for unfetched domain" with a command similar to this:
# grep -A2 'Refreshing domain 534432b5-c19b-4181-9764-aee420a931f6' /var/log/vdsm/vdsm.log

Actual results:
Will print the messages from the beginning of the description.

Expected results:
Should not print those messages as ERRORs.
Comment 1 Eduardo Warszawski 2013-11-25 03:58:34 EST

*** This bug has been marked as a duplicate of bug 990070 ***
Comment 2 Marina 2013-11-25 08:56:32 EST
Eduardo, the bug https://bugzilla.redhat.com/show_bug.cgi?id=990070 is closed with explanation saying on FC it will not happen.
Running 
# rpm -qa vdsm
vdsm-4.13.0-0.5.beta1.el6ev.x86_6

I still see this error:
Thread-28::ERROR::2013-11-15 14:57:14,689::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 5f8d2599-21a5-462f-9ec0-499222951ca2

And this environment is using iSCSI only.
I am reopening this bug to get more explanations please why this should be closed.

Thank you.
Comment 3 Marina 2013-11-25 09:26:48 EST
I am sorry, just tested this again.
And this is not happening.
Closing this bug.

*** This bug has been marked as a duplicate of bug 990070 ***

Note You need to log in before you can comment on or make changes to this bug.