Bug 990070 - "looking for unfetched domain" error in loop in VDSM logs
"looking for unfetched domain" error in loop in VDSM logs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Eduardo Warszawski
Aharon Canan
storage
: Triaged
: 959745 1031881 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 06:30 EDT by Aharon Canan
Modified: 2016-02-10 11:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 09:10:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
logs (2.07 MB, application/x-gzip)
2013-07-30 06:31 EDT, Aharon Canan
no flags Details

  None (edit)
Description Aharon Canan 2013-07-30 06:30:39 EDT
Description of problem:
errors appear in loop in vdsm logs without doing anything

Version-Release number of selected component (if applicable):
sf19

How reproducible:
alway

Steps to Reproduce:
1. install 3.2.2 with 2 hosts, 2 SDs and 1 VM
2.
3.

Actual results:
error "looking for unfetched domain" and appears in loop in vdsm logs without doing anything

Expected results:
shouldn't appear

Additional info:
Thread-468::ERROR::2013-07-30 12:16:31,014::libvirtvm::2149::vm.Vm::(snapshot) vmId=`ee68c161-275d-425d-96ac-9be68c33ae79`::Unable to take snapshot
Thread-342::ERROR::2013-07-30 12:17:12,640::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 0c59428e-0dba-46d2-82d1-2d1438332009
Thread-342::ERROR::2013-07-30 12:17:12,641::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 0c59428e-0dba-46d2-82d1-2d1438332009
Thread-354::ERROR::2013-07-30 12:17:31,644::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 3f0176a2-7c96-4eaa-ae05-422dbf8b6375
Thread-354::ERROR::2013-07-30 12:17:31,645::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 3f0176a2-7c96-4eaa-ae05-422dbf8b6375
Thread-296::ERROR::2013-07-30 12:20:51,604::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 699d358c-3e60-4e9b-a3e8-332eb6eb14a6
Thread-296::ERROR::2013-07-30 12:20:51,604::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 699d358c-3e60-4e9b-a3e8-332eb6eb14a6
Thread-342::ERROR::2013-07-30 12:22:13,298::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 0c59428e-0dba-46d2-82d1-2d1438332009
Thread-342::ERROR::2013-07-30 12:22:13,299::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 0c59428e-0dba-46d2-82d1-2d1438332009
Thread-354::ERROR::2013-07-30 12:22:32,282::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 3f0176a2-7c96-4eaa-ae05-422dbf8b6375
Thread-354::ERROR::2013-07-30 12:22:32,282::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 3f0176a2-7c96-4eaa-ae05-422dbf8b6375
Thread-296::ERROR::2013-07-30 12:25:52,425::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 699d358c-3e60-4e9b-a3e8-332eb6eb14a6
Thread-296::ERROR::2013-07-30 12:25:52,426::sdc::153::Storage.StorageDomainCache::(_findUnfetchedDomain) looking for domain 699d358c-3e60-4e9b-a3e8-332eb6eb14a6
Thread-342::ERROR::2013-07-30 12:27:13,936::sdc::137::Storage.StorageDomainCache::(_findDomain) looking for unfetched domain 0c59428e-0dba-46d2-82d1-2d1438332009
Comment 1 Aharon Canan 2013-07-30 06:31:08 EDT
Created attachment 780533 [details]
logs
Comment 3 Eduardo Warszawski 2013-08-09 09:10:30 EDT
In 3.3 (target release) the prefetch for block devices is enabled.
Therefore in the target release the log should not appear.

The severity of the log issued is not a bug.

For FC pools, engine is not sending connectStorageServer(). This will cause FC domains not to be prefetched and the log to appear.

This has nothing to do with vdsm.
Comment 4 Eduardo Warszawski 2013-08-12 09:57:47 EDT
*** Bug 959745 has been marked as a duplicate of this bug. ***
Comment 5 Eduardo Warszawski 2013-11-25 03:58:34 EST
*** Bug 1031881 has been marked as a duplicate of this bug. ***
Comment 6 Marina 2013-11-25 09:26:48 EST
*** Bug 1031881 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.