Bug 1032161 - pcs cluster standby nodename doesn't work
pcs cluster standby nodename doesn't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Chris Feist
: Reopened, ZStream
Depends On: 1029129
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 11:03 EST by Jan Kurik
Modified: 2013-12-17 05:10 EST (History)
14 users (show)

See Also:
Fixed In Version: pcs-0.9.90-2.el6_5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 05:10:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 545793 None None None Never

  None (edit)
Description Jan Kurik 2013-11-19 11:03:30 EST
This bug has been copied from bug #1029129 and has been proposed
to be backported to 6.5 z-stream (EUS).
Comment 4 RHEL Product and Program Management 2013-11-27 17:26:20 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 5 xrobau 2013-11-27 21:09:29 EST
I'd like to appeal this, please.

This is _critical functionality_ of Clustering - the ability to set a node to standby status.

Whilst there are workarounds for this specific issue, there are numerous other high priority bugs that are caused by this.

Whilst I didn't outline them all, there are at least 10 other cluster-breaking bugs in PCS caused by this.

https://bugzilla.redhat.com/show_bug.cgi?id=1029129#c9

(I realise that Fabio Di Nitto has already reopened this, and if this was closed in error, then I apologise, but I thought I better make sure everyone's aware that this is a critical level issue)
Comment 6 Chris Feist 2013-12-02 18:59:31 EST
This was closed in error (and has been re-opened).

I've also look at the https://bugzilla.redhat.com/show_bug.cgi?id=1029129#c9, I don't believe there are 10 other cluster-breaking bugs.  The majority of the times that function is called it is called in commands that are not supported in RHEL 6.5 (generally commands that require pcsd or commands that operate on remote nodes).

The only two bugs that have come out of that issue are this bug & https://bugzilla.redhat.com/show_bug.cgi?id=1019410 (cluster standby and fence/stonith levels).  If you do see other issues please let me know and/or file new bugs against pcs.
Comment 7 Chris Feist 2013-12-08 17:25:15 EST
Test Results: (ask-01 doesn't exist)

[root@ask-02 ~]# rpm -q pcs
pcs-0.9.90-2.el6_5.2.noarch
[root@ask-02 ~]# pcs status | grep ask-02
Online: [ ask-02 ask-03 ]
[root@ask-02 ~]# pcs cluster standby ask-01
Error: node 'ask-01' does not appear to exist in configuration
[root@ask-02 ~]# pcs cluster standby ask-02
[root@ask-02 ~]# pcs status | grep ask-02
Node ask-02: standby
[root@ask-02 ~]#
Comment 11 errata-xmlrpc 2013-12-17 05:10:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1848.html

Note You need to log in before you can comment on or make changes to this bug.