Bug 1032295 - [abrt] pidgin-2.10.7-3.fc19: sighandler: Process /usr/bin/pidgin was killed by signal 6 (SIGABRT) [NEEDINFO]
[abrt] pidgin-2.10.7-3.fc19: sighandler: Process /usr/bin/pidgin was killed b...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: farstream (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:84dbbc72702551c723a8f5670e1...
:
: 1028784 1124989 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-19 17:56 EST by long
Modified: 2015-03-23 03:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: farstream-0.1.2-10.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-13 13:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mike: needinfo? (dan.mashal)


Attachments (Terms of Use)
File: backtrace (44.28 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: cgroup (141 bytes, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: core_backtrace (46.05 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: dso_list (21.37 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: environ (1.84 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: maps (116.25 KB, text/plain)
2013-11-19 17:56 EST, long
no flags Details
File: open_fds (2.59 KB, text/plain)
2013-11-19 17:57 EST, long
no flags Details
File: proc_pid_status (937 bytes, text/plain)
2013-11-19 17:57 EST, long
no flags Details
File: var_log_messages (242 bytes, text/plain)
2013-11-19 17:57 EST, long
no flags Details
farstream patch try 1 (1.19 KB, patch)
2014-08-08 13:14 EDT, Michael Cronenworth
no flags Details | Diff

  None (edit)
Description long 2013-11-19 17:56:33 EST
Description of problem:
I have no idea how this happened.  I wasn't even actively using it at the time.

Version-Release number of selected component:
pidgin-2.10.7-3.fc19

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        pidgin --session 101681b6105f8000138057461400000020540055 --display :0
crash_function: sighandler
executable:     /usr/bin/pidgin
kernel:         3.11.7-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 sighandler
 #4 _send_src_pad_blocked_callback at /usr/lib64/gstreamer-0.10/libfsrtpconference.so
 #5 handle_pad_block at /lib64/libgstreamer-0.10.so.0
 #6 gst_pad_alloc_buffer_full at /lib64/libgstreamer-0.10.so.0
 #7 gst_tee_buffer_alloc at /usr/lib64/gstreamer-0.10/libgstcoreelements.so
 #8 gst_pad_alloc_buffer_full at /lib64/libgstreamer-0.10.so.0
 #9 gst_proxy_pad_bufferalloc_default at /lib64/libgstreamer-0.10.so.0
 #10 gst_pad_alloc_buffer_full at /lib64/libgstreamer-0.10.so.0
 #11 gst_valve_buffer_alloc at /usr/lib64/gstreamer-0.10/libgstcoreelements.so
 #12 gst_pad_alloc_buffer_full at /lib64/libgstreamer-0.10.so.0
Comment 1 long 2013-11-19 17:56:41 EST
Created attachment 826343 [details]
File: backtrace
Comment 2 long 2013-11-19 17:56:44 EST
Created attachment 826344 [details]
File: cgroup
Comment 3 long 2013-11-19 17:56:46 EST
Created attachment 826345 [details]
File: core_backtrace
Comment 4 long 2013-11-19 17:56:49 EST
Created attachment 826346 [details]
File: dso_list
Comment 5 long 2013-11-19 17:56:52 EST
Created attachment 826347 [details]
File: environ
Comment 6 long 2013-11-19 17:56:55 EST
Created attachment 826348 [details]
File: limits
Comment 7 long 2013-11-19 17:56:59 EST
Created attachment 826349 [details]
File: maps
Comment 8 long 2013-11-19 17:57:01 EST
Created attachment 826350 [details]
File: open_fds
Comment 9 long 2013-11-19 17:57:04 EST
Created attachment 826351 [details]
File: proc_pid_status
Comment 10 long 2013-11-19 17:57:07 EST
Created attachment 826352 [details]
File: var_log_messages
Comment 11 Egon Kastelijn 2013-12-21 08:15:29 EST
In my case the Pidgin crash occurred when I tried to accept a SIPE audio call from a Windows Lync 2013 client.

I registered this bug for it:
https://sourceforge.net/p/sipe/bugs/230/
Which turns out to be a duplicate of:
https://sourceforge.net/p/sipe/bugs/217/
Which in refers to:
https://sourceforge.net/p/sipe/discussion/688534/thread/465db4ab/

This suggests that the problem is related to "farstream".
Comment 12 long 2013-12-23 10:21:56 EST
I suspect my crash would also be related to Lync 2013 as we just started using it around here.
Comment 13 Egon Kastelijn 2013-12-25 14:12:50 EST
I registered a bug for this with the Pidgin SIPE plugin maintainers.
http://sourceforge.net/p/sipe/bugs/230/ 
After looking at the backtrace the conclusion is that no code paths inside SIPE are involved in the crash, just gstreamer & farstream.
Comment 14 Fedora Admin XMLRPC Client 2014-02-17 08:01:41 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Fedora Admin XMLRPC Client 2014-02-17 08:03:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Michael Cronenworth 2014-07-30 15:29:39 EDT
*** Bug 1124989 has been marked as a duplicate of this bug. ***
Comment 17 Michael Cronenworth 2014-08-08 13:14:35 EDT
Created attachment 925254 [details]
farstream patch try 1

So I caught this in gdb and found the problem easily enough.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f13d139a700 (LWP 30767)]
0x00007f13ebdd5115 in _send_src_pad_blocked_callback (pad=0x2611c60, 
    blocked=<optimized out>, user_data=<optimized out>)
    at fs-rtp-session.c:3864
3864	        error->message);
(gdb) p error
$1 = (GError *) 0x0

Farstream is clearing the error pointer and then not re-initializing it. I noticed 3 possible areas where the error pointer should have been re-initialized. The attached patch appears to fix this issue. Instead of crashing I get a "A non-recoverable Farstream error has occurred." message.
Comment 18 Oren Oichman 2014-08-20 05:17:22 EDT
Another user experienced a similar problem:

when getting a call over lync, before I had a chance to answer the call
the application crashed

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        pidgin
crash_function: sighandler
executable:     /usr/bin/pidgin
kernel:         3.15.10-200.fc20.x86_64
package:        pidgin-2.10.9-1.fc20
reason:         pidgin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 19 Michael Cronenworth 2014-08-20 18:32:41 EDT
@Dan, could you apply my patch?
Comment 20 Michael Cronenworth 2014-09-04 11:22:54 EDT
*** Bug 1028784 has been marked as a duplicate of this bug. ***
Comment 21 Alessandro Surace 2014-12-09 09:54:31 EST
Guys any update to this bug?
Comment 22 Oren Oichman 2015-02-23 06:59:11 EST
Another user experienced a similar problem:

trying to answer a SIP call

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        pidgin --session 205e8dcdb-957b-46e2-90e6-fbc4e732e523 --display :0.0
crash_function: sighandler
executable:     /usr/bin/pidgin
kernel:         3.18.7-100.fc20.x86_64
package:        pidgin-2.10.10-3.fc20
reason:         pidgin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Fedora Update System 2015-03-06 17:31:39 EST
farstream-0.1.2-10.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/farstream-0.1.2-10.fc22
Comment 24 Fedora Update System 2015-03-06 17:32:23 EST
farstream-0.1.2-10.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/farstream-0.1.2-10.fc21
Comment 25 Fedora Update System 2015-03-06 17:33:33 EST
farstream-0.1.2-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/farstream-0.1.2-10.fc20
Comment 26 Fedora Update System 2015-03-09 04:24:40 EDT
Package farstream-0.1.2-10.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing farstream-0.1.2-10.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3405/farstream-0.1.2-10.fc22
then log in and leave karma (feedback).
Comment 27 Fedora Update System 2015-03-13 13:22:45 EDT
farstream-0.1.2-10.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2015-03-23 03:08:27 EDT
farstream-0.1.2-10.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2015-03-23 03:10:26 EDT
farstream-0.1.2-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.