Bug 103247 - libpq.so.2 link not created
libpq.so.2 link not created
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-27 22:05 EDT by Vladimir Ivanovic
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 09:00:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Ivanovic 2003-08-27 22:05:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Although the rpm package shows a link as part of the package (downloaded with
up2date):

   $ rpm -qvlp /var/spool/up2date/postgresql-libs-7.3.2-3.i386.rpm

   [...]
   lrwxrwxrwx    1 root    root               10 Feb 15  2003 \    
   /usr/lib/libpq.so.2.0 -> libpq.so.2
   [...]

no such link is created. Programs that expect libpq.so.2 to exist fail to run.

Version-Release number of selected component (if applicable):
postgresql-libs-7.3.2-3

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps postgresql-libs
2. up2date -d postgresql-libs
3. rpm -qvlp /var/spool/up2date/postgresql-libs*.rpm
4. rpm -Uvh /var/spool/up2date/postgresql-libs*.rpm
5. Run a program that requires libpq.so.2 (e.g. my build of XEmacs)

Actual Results:  Program does not run because it cannot find libpq.so.2.

Expected Results:  The world's finest editor, nay, an operating system desguised
as an editor, proudly displaying it's startup screen.

Additional info:

   cd /usr/lib
   ln -s libpq.so.3 libpq.so.2

fixes the problem.
Comment 1 Andrew Overholt 2003-08-28 09:00:45 EDT
Fixed in rawhide.  If you need libpq.so.2 functionality, please install
postgresql72-libs (see Bug #97391 ... the initial one mistakenly didn't have ssl
support (among other things)).  Closing.

Note You need to log in before you can comment on or make changes to this bug.