Bug 1032506 - [abrt] evolution-3.8.5-2.fc19: call_old_file_Sync: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.8.5-2.fc19: call_old_file_Sync: Process /usr/bin/evolution...
Status: CLOSED DUPLICATE of bug 859691
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:a29c0eae90cea0386f544983ab7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-20 05:15 EST by David Woodhouse
Modified: 2014-08-21 13:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (95.40 KB, text/plain)
2013-11-20 05:15 EST, David Woodhouse
no flags Details
File: cgroup (143 bytes, text/plain)
2013-11-20 05:15 EST, David Woodhouse
no flags Details
File: core_backtrace (71.54 KB, text/plain)
2013-11-20 05:15 EST, David Woodhouse
no flags Details
File: dso_list (29.69 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: environ (2.04 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: maps (148.73 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: open_fds (3.40 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: proc_pid_status (968 bytes, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details
File: var_log_messages (14.36 KB, text/plain)
2013-11-20 05:16 EST, David Woodhouse
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 712591 None None None Never

  None (edit)
Description David Woodhouse 2013-11-20 05:15:42 EST
Description of problem:
No idea; was just typing an email. System was very slow and swappy; perhaps exacerbated a race condition. There are global variables in this code...

Version-Release number of selected component:
evolution-3.8.5-2.fc19

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        evolution
crash_function: call_old_file_Sync
executable:     /usr/bin/evolution
kernel:         3.11.7-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (3 frames)
 #0 call_old_file_Sync at camel-db.c:67
 #1 sync_request_thread_cb at camel-db.c:94
 #3 g_thread_proxy at gthread.c:798

Potential duplicate: bug 859691
Comment 1 David Woodhouse 2013-11-20 05:15:50 EST
Created attachment 826524 [details]
File: backtrace
Comment 2 David Woodhouse 2013-11-20 05:15:53 EST
Created attachment 826525 [details]
File: cgroup
Comment 3 David Woodhouse 2013-11-20 05:15:57 EST
Created attachment 826526 [details]
File: core_backtrace
Comment 4 David Woodhouse 2013-11-20 05:16:01 EST
Created attachment 826527 [details]
File: dso_list
Comment 5 David Woodhouse 2013-11-20 05:16:06 EST
Created attachment 826528 [details]
File: environ
Comment 6 David Woodhouse 2013-11-20 05:16:11 EST
Created attachment 826529 [details]
File: limits
Comment 7 David Woodhouse 2013-11-20 05:16:16 EST
Created attachment 826530 [details]
File: maps
Comment 8 David Woodhouse 2013-11-20 05:16:19 EST
Created attachment 826531 [details]
File: open_fds
Comment 9 David Woodhouse 2013-11-20 05:16:22 EST
Created attachment 826532 [details]
File: proc_pid_status
Comment 10 David Woodhouse 2013-11-20 05:16:25 EST
Created attachment 826533 [details]
File: var_log_messages
Comment 11 David Woodhouse 2013-11-20 05:20:21 EST
Also filed upstream, but it's called "Obsolete" there, while in Fedora it is still the latest bleeding-edge, shipped in the very newest stable version of the distribution. So I suppose it needs to be handled here rather than CLOSED/UPSTREAM.
Comment 12 Milan Crha 2013-11-21 05:26:26 EST
Well, I do not like to duplicate the effort by filling basically the same comments in two bugzillas - it's time consuming and tends to break when I forget of the connection between them.

*** This bug has been marked as a duplicate of bug 859691 ***
Comment 13 David Woodhouse 2013-11-21 06:19:13 EST
(In reply to Milan Crha from comment #12)
> Well, I do not like to duplicate the effort by filling basically the same
> comments in two bugzillas - it's time consuming and tends to break when I
> forget of the connection between them.

That's fair enough. I'm aware that we fulfil more than one rôle — sometimes acting as 'upstream' and sometimes 'downstream'. But in this case upstream has clearly marked 3.8 as obsolete, while Fedora cannot tolerate that since it's still the latest release we've shipped.

So perhaps we should put on our 'downstream' hat (fedora) and argue with our 'upstream' hat that it would be better not to mark 3.8 as 'obsolete' in GNOME bugzilla just yet... :)
Comment 14 Milan Crha 2013-11-22 05:07:34 EST
:) My point would be more about "even the bug was found/noticed in 3.8, maybe it's still relevant on 3.10", because I didn't find any directly related change in 3.10 which would, even marginally, address the crash.

Note You need to log in before you can comment on or make changes to this bug.