Bug 1032936 - Display 1 always pop out when using virt-viewer to relaunch guest
Summary: Display 1 always pop out when using virt-viewer to relaunch guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jonathon Jongsma
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1179477
Blocks: 1009648 1032939
TreeView+ depends on / blocked
 
Reported: 2013-11-21 09:31 UTC by tingting zheng
Modified: 2015-07-22 06:30 UTC (History)
10 users (show)

Fixed In Version: virt-viewer-2.0-1.el6
Doc Type: Bug Fix
Doc Text:
The first guest display was re-enabled after a guest reboot even when it was previously disabled on the guest. This update removes the fixed association between the the main guest window and a specific guest display number, which prevents the problem from occurring.
Clone Of:
: 1032939 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:30:53 UTC


Attachments (Terms of Use)
sceenshot of the issue (492.09 KB, image/png)
2013-11-21 09:31 UTC, tingting zheng
no flags Details
spice debug log file for disable display 1 and enable display 2 (46.26 KB, text/plain)
2013-11-21 09:32 UTC, tingting zheng
no flags Details
spice debug log file for relaunch virt-viewer (134.87 KB, text/plain)
2013-11-21 09:33 UTC, tingting zheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1322 normal SHIPPED_LIVE virt-viewer and spice-gtk bug fix and enhancement update 2015-07-20 17:53:14 UTC

Description tingting zheng 2013-11-21 09:31:04 UTC
Created attachment 827093 [details]
sceenshot of the issue

Description
Display 1 always pop out when using virt-viewer to relaunch guest

Version:
libvirt-0.10.2-29.el6.1.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-xpi-2.7-24.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest with qxl and spicevmc.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg:display 2.
# virt-viewer $guest --spice-debug --debug > spice-debug-1.log
3.Close virt-viewer.
4.Use virt-viewer to relaunch the guest,both display 1 and display 2 will be launched,display 1 will show:waiting for display 1,see the screenshot.
# virt-viewer $guest --spice-debug --debug > spice-debug-2.log

Actual results:
As description.

Expected results:
Step 4,only display 2 launched.

Additional info:
1.Attached the spice debug info.
2.The issue can also be reproduced on rhel7.

Comment 1 tingting zheng 2013-11-21 09:32:55 UTC
Created attachment 827098 [details]
spice debug log file for disable display 1 and enable display 2

Comment 2 tingting zheng 2013-11-21 09:33:35 UTC
Created attachment 827100 [details]
spice debug log file for relaunch virt-viewer

Comment 3 CongDong 2014-06-19 02:55:16 UTC
Hi jjongsma:

I found a problem, but I'm not sure it's same with this or not.
Could you help me to check it?

I test with virt-viewer-0.6.0-7.el6

Steps:
1. use virt-viewer to connect a rhel spice guest
#virt-viewer $vm
2. enable 4 displays
Click "View" -> "Displays" -> "Display(1,2,3,4)"
3. disable display 2
Click "View" -> "Displays" -> "Display 2"
4. run "xrandr" in guest
5. close virt-viewer
6. reconnect guest with virt-viewer
#virt-viewer $vm

Result:
Step 4, after disable display 2, xrandr in guest still show 4 displays.
Step 6, after reconnect the guest, 4 displays will come out.

if it's a different problem, I'll file a new one to track it.
Thanks

Comment 4 Jonathon Jongsma 2014-06-19 14:52:56 UTC
Hi CongDong,

The scenario in comment #3 is a different issue.

Comment 5 CongDong 2014-06-20 02:56:19 UTC
(In reply to Jonathon Jongsma from comment #4)
> Hi CongDong,
> 
> The scenario in comment #3 is a different issue.

Thanks, and I file a new bug for it: Bug 1111425

Comment 7 Fabiano Fidêncio 2014-10-29 14:47:43 UTC
It's already fixed upstream by the commits:

573c1cfc9118b730f2ff5aa6a7d45529f2978fbf
0e6735b4a4f1c21364781f97630ec1a12a82fd60
453704789036551aa61bf19bc369c8c5709e49f3
f03285ba8da4a40a8058c3259788293124cc2803
29c8cadd4037681e8eb417fd8a0bb6cc6170a6b3
a15bbac32001d8fb9eea5e6149df2aa2231f1a4f
910ee34248d98bd9f328c3f3e92120d49f55dedc
804564e2460011dfbf3f195aa8931b15d98f8824

Comment 8 Jonathon Jongsma 2015-02-09 16:37:33 UTC
This will be fixed by rebase to 2.0

Comment 10 CongDong 2015-03-11 07:45:38 UTC
Can reproduce with:
virt-viewer-0.6.0-11.el6

Steps:
1.Prepare a spice guest with qxl and spicevmc.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg:display 2.
# virt-viewer $guest --spice-debug --debug > spice-debug-1.log
3.Close virt-viewer.
4.Use virt-viewer to relaunch the guest,both display 1 and display 2 will be launched,display 1 will show:waiting for display 1

Verify with:
virt-viewer-2.0-2.el6

Reslut:
Step4, only display 2 comes out, display 1 is disabled.

As the result, move VERIFIED.

Comment 12 errata-xmlrpc 2015-07-22 06:30:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1322.html


Note You need to log in before you can comment on or make changes to this bug.