Bug 1032939 - Display 1 always pop out when using virt-viewer to relaunch guest
Display 1 always pop out when using virt-viewer to relaunch guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jonathon Jongsma
Virtualization Bugs
:
Depends On: 1032936
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-11-21 04:36 EST by tingting zheng
Modified: 2015-07-16 11:06 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-8.el7
Doc Type: Bug Fix
Doc Text:
The first guest display was re-enabled after a guest reboot even when it was previously disabled on the guest. This update removes the fixed association between the the main guest window and a specific guest display number, which prevents the problem from occurring.
Story Points: ---
Clone Of: 1032936
Environment:
Last Closed: 2015-03-05 08:38:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2013-11-21 04:36:29 EST
The bug can also be reproduced on rhel7,so cloned the bug.
version:
libvirt-1.1.1-12.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-gtk-0.20-6.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-glib-0.20-6.el7.x86_64
spice-xpi-2.8-4.el7.x86_64

+++ This bug was initially created as a clone of Bug #1032936 +++

Description
Display 1 always pop out when using virt-viewer to relaunch guest

Version:
libvirt-0.10.2-29.el6.1.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-xpi-2.7-24.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest with qxl and spicevmc.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg:display 2.
# virt-viewer $guest --spice-debug --debug > spice-debug-1.log
3.Close virt-viewer.
4.Use virt-viewer to relaunch the guest,both display 1 and display 2 will be launched,display 1 will show:waiting for display 1,see the screenshot.
# virt-viewer $guest --spice-debug --debug > spice-debug-2.log

Actual results:
As description.

Expected results:
Step 4,only display 2 launched.

Additional info:
1.Attached the spice debug info.
2.The issue can also be reproduced on rhel7.

--- Additional comment from tingting zheng on 2013-11-21 04:32:55 EST ---



--- Additional comment from tingting zheng on 2013-11-21 04:33:35 EST ---
Comment 2 CongDong 2013-12-17 00:44:40 EST
Can reproduce this with:
# rpm -qa virt-viewer
virt-viewer-0.5.7-3.el7.x86_64

Steps:
1.Prepare a spice guest with qxl and spicevmc.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg:display 2.
# virt-viewer $guest --spice-debug --debug > spice-debug-1.log
3.Close virt-viewer.
4.Use virt-viewer to relaunch the guest,both display 1 and display 2 will be launched,display 1 will show:waiting for display 1,see the screenshot.
# virt-viewer $guest --spice-debug --debug > spice-debug-2.log

Result:
Display 1 come out, show a message:
Waiting for display 1 ...
Comment 3 RHEL Product and Program Management 2014-03-24 01:50:39 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Jonathon Jongsma 2014-08-19 11:28:03 EDT
I'm investigating what it would take to fix this...
Comment 6 Jonathon Jongsma 2014-08-26 17:52:46 EDT
Some patches posted to Mailing list, but they need careful review: https://www.redhat.com/archives/virt-tools-list/2014-August/msg00094.html
Comment 8 CongDong 2014-10-14 03:09:15 EDT
Can reproduce with virt-viewer-0.6.0-7.el7.x86_64

VERIFY with: virt-viewer-0.6.0-8.el7.x86_64

Steps:
1.Prepare a spice guest with qxl and spicevmc.
2.Boot the guest,use virt-viewer to launch the guest,disable display 1 and enable other displays,eg:display 2.
# virt-viewer $guest --spice-debug --debug > spice-debug-1.log
3.Close virt-viewer.
4.Use virt-viewer to relaunch the guest
# virt-viewer $guest

Result:
Step4, only display 2 comes out

As the result, set VERIFIED.
Comment 10 errata-xmlrpc 2015-03-05 08:38:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.