Bug 1032947 - BPEL Console - can't be loaded (hangs on loading screen) on IE8/IE9/IE10
BPEL Console - can't be loaded (hangs on loading screen) on IE8/IE9/IE10
Status: NEW
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: BPEL Integration (Show other bugs)
6.0.0
Unspecified Windows
unspecified Severity unspecified
: ER6
: 6.0.0
Assigned To: Eric Wittmann
Matej Melko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 04:44 EST by lvaskova
Modified: 2018-01-29 21:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The BPEL console may fail to load if you are using Internet Explorer 10 due to the version of GWT supplied. The failure is caused by a check to determine whether Adobe Flash is present or not. To workaround this issue please upgrade to Internet Explorer 11 or install Flash. If that fails, see the bug ticket for an alternative possible workaround.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lvaskova 2013-11-21 04:44:20 EST
Description of problem:

Can't load BPEL console in Windows using Internet Explorer 9.

How reproducible:
every time

Steps to Reproduce:
1. run server (operating system: Windows Server Enterprise)
2. go to: http://localhost:8080/bpel-console/
3. bpel console is not able to load
Comment 1 lvaskova 2013-11-21 09:44:32 EST
Same issue on: Windows Server Enterprise 2003 - Internet Explorer 8
Comment 2 Andrej Vano 2013-11-22 08:15:17 EST
This issue persist on IE10 (windows server 2012)
Comment 3 Eric Wittmann 2013-12-17 08:01:36 EST
I have verified this on Windows 7 + IE 10 as well.  The first error being hit is a bug in GWT 2.0.4 for IE when performing a check for Flash support.  If you install Flash you will likely get past that issue.  The only other workaround is to patch the GWT generated javascript.  This problem has already by encountered here:

  https://bugzilla.redhat.com/show_bug.cgi?id=790019

However, once I installed Flash it *still* didn't work for me.  Instead I ran into the following error:

07:57:02.618 [ERROR] [app] Failed to create an instance of 'org.jboss.errai.workspaces.client.Application' via deferred binding 

com.google.gwt.core.client.JavaScriptException: (InvalidCharacterError): InvalidCharacterError

I have no idea how to solve or workaround this issue.  The error is coming out of the Errai Workspaces code, which is a feature of Errai that was removed a long time ago.

I'm not sure what else to try...
Comment 4 Christian Sadilek 2013-12-17 10:26:13 EST
Are you using any of the functionality provided by the workspaces module? If not, I'd suggest removing the module from the classpath and rebuilding the application. As Eric pointed out, we removed that module from the Errai codebase about 2.5 years ago.

Does it work on older versions of IE? If so, you could try adding the x-ua-compatible meta tag to your host page (i.e. <meta http-equiv="x-ua-compatible" content="IE=8"/>)
Comment 5 Eric Wittmann 2013-12-17 13:58:51 EST
I'm splitting the InvalidCharacterError into a separate BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1044082

As for *this* defect, the issues is that if Flash is not installed there is an error in the generated GWT code that prevents the page from loading.  The easiest workaround is to simply install Flash.

The only possibilities for fixing this would be to patch the generated GWT code after/during the build or else possibly upgrade GWT.  Neither of these are quick or great options, in my opinion.

Sadly I think this should be a documentation issue:  "install flash to use the bpel console".

PS: thanks to @csadilek for the x-ua-compatible meta-data suggestion.  That actually worked for the InvalidCharacterError error!
Comment 7 lvaskova 2014-01-22 10:42:44 EST
CR1: Workaround is not working.
Still a problem with IE10 even with flash installed.
Comment 8 Eric Wittmann 2014-01-22 13:59:14 EST
Oy!  This workaround worked for me in both of my local VMs (Windows 8 and Windows 7).  It also worked for me when testing against one of the QE VMs.  Specifically this one:

10.16.92.115

I did this:

1) connect to VM @ the above IP
2) open IE, 11.0.9600.16476
3) navigate to bpel-console, it failed to load
4) installed Flash v12.0.0.38
5) reloaded bpel-console, it WORKED!!

I realize this test was done with IE11 - I need access to an IE10 machine to test further.

Note You need to log in before you can comment on or make changes to this bug.