Bug 1032967 - option -f will not launch all the display as fullscreen
option -f will not launch all the display as fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Virtualization Bugs
:
Depends On: 1032960 1109400
Blocks: 1009648
  Show dependency treegraph
 
Reported: 2013-11-21 05:19 EST by CongDong
Modified: 2015-03-05 08:38 EST (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: When starting with -f and N monitors, only displays with number <= N were set to fullscreen Consequence: For guests with sparse displays enabled (e.g. 1 & 4), display number 4 was not set to fullscreen Fix: When started in fullscreen mode (-f), we now always auto-configure the guest to match the client configuration (e.g. if client has 2 monitors, we enable display 1 and 2 on guest and disable any other displays) Result: There is always one screen for each client monitor and they are all fullscreen.
Story Points: ---
Clone Of: 1032960
Environment:
Last Closed: 2015-03-05 08:38:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer and spice log (70.73 KB, text/x-log)
2013-11-21 05:19 EST, CongDong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0295 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2015-03-05 12:33:00 EST

  None (edit)
Description CongDong 2013-11-21 05:19:17 EST
Created attachment 827118 [details]
virt-viewer and spice log

+++ This bug was initially created as a clone of Bug #1032960 +++
Can reproduce this on rhel7 with:
# rpm -qa virt-viewer spice*
spice-glib-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64

But on rhel7, there is another problem, the display 1 is fullscreen mode, but the window is "Minimize Window"


Description of problem:
Display 3 and display 4 can not be fullscreen automatically 
with option -f on the host has two physical monitors.

Version-Release number of selected component (if applicable):
# rpm -qa virt-viewer spice*
spice-gtk-0.20-9.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-9.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-9.el6.x86_64
spice-client-0.8.2-15.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest with qxl and spicevmc.
2.Start the guest,connect it with virt-viewer,enable display 1 and display 4(or 3).
# virt-viewer $guest
3.Close virt-viewer.
4.Use virt-viewer to connect the guest with option "-f"
# virt-viewer $guest -f
5.Repeat step2-step4 with display 1 and display 2

Actual results:
Step4, display 1 is fullscreen, but display 4 is in window mode.
Step5, display 1 and display 2 are all fullscreen.

Expected results:
Fullscreen mode should work well with every combination.

Additional info:

--- Additional comment from CongDong on 2013-11-21 05:07:05 EST ---



--- Additional comment from CongDong on 2013-11-21 05:07:59 EST ---



--- Additional comment from CongDong on 2013-11-21 05:09:07 EST ---

Guest xrandr:
# xrandr
Screen 0: minimum 320 x 200, current 2080 x 1050, maximum 8192 x 8192
qxl-0 connected 1680x1050+0+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0* 
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   1064x795-0      0.1  
qxl-1 disconnected
   936x850-1       0.1  
   936x405-1       0.1  
qxl-2 disconnected
   1208x718-2      0.1  
qxl-3 connected 400x375+1680+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   976x664-3       0.1  
   400x375-3       0.1* 


Host xrandr:
# xrandr
Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+   74.9  
   1600x1000      60.0  
   1280x1024      75.0     72.0     60.0  
   1440x900       75.0     59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DVI-1 connected 1280x1024+1680+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1
Comment 2 RHEL Product and Program Management 2014-03-24 01:50:32 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Marc-Andre Lureau 2014-07-03 10:03:47 EDT
Like original bug, this should be solved with rebase 1109400
Comment 6 CongDong 2014-07-22 06:27:37 EDT
I can reproduce this with: virt-viewer-0.5.7-7.el7.x86_64

VERIFY with: 
virt-viewer-0.6.0-1.el7.x86_64.rpm

Steps:
1.Prepare a spice guest with qxl and spicevmc.
2.Start the guest,connect it with virt-viewer,enable display 1 and display 4(or 3).
# virt-viewer $guest
3.Close virt-viewer.
4.Use virt-viewer to connect the guest with option "-f"
# virt-viewer $guest -f
5.Click "Leave fullscreen" button


Result:
Step4, two displays are fullscreen in each monitor
Step5, after leave fullscreen, check two display number, they are display 1 and display 2

The result is expected, so set VERIFIED
Comment 8 errata-xmlrpc 2015-03-05 08:38:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.