Bug 1032960 - option -f will not launch all the display as fullscreen
option -f will not launch all the display as fullscreen
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1027381
Blocks: 1009648 1032967
  Show dependency treegraph
 
Reported: 2013-11-21 05:05 EST by CongDong
Modified: 2014-10-14 02:30 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1032967 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:30:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer and spice log (109.73 KB, text/x-log)
2013-11-21 05:07 EST, CongDong
no flags Details
screenshot on host (2.67 MB, image/png)
2013-11-21 05:07 EST, CongDong
no flags Details
display2 has black background and cannot hold the right click menu (1.03 MB, image/png)
2014-06-05 05:19 EDT, CongDong
no flags Details
virt-viewer log with spice debug option for comment 9 (69.23 KB, text/plain)
2014-06-05 05:21 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-11-21 05:05:53 EST
Description of problem:
Display 3 and display 4 can not be fullscreen automatically 
with option -f on the host has two physical monitors.

Version-Release number of selected component (if applicable):
# rpm -qa virt-viewer spice*
spice-gtk-0.20-9.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-9.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-9.el6.x86_64
spice-client-0.8.2-15.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest with qxl and spicevmc.
2.Start the guest,connect it with virt-viewer,enable display 1 and display 4(or 3).
# virt-viewer $guest
3.Close virt-viewer.
4.Use virt-viewer to connect the guest with option "-f"
# virt-viewer $guest -f
5.Repeat step2-step4 with display 1 and display 2

Actual results:
Step4, display 1 is fullscreen, but display 4 is in window mode.
Step5, display 1 and display 2 are all fullscreen.

Expected results:
Fullscreen mode should work well with every combination.

Additional info:
Comment 1 CongDong 2013-11-21 05:07:05 EST
Created attachment 827105 [details]
virt-viewer and spice log
Comment 2 CongDong 2013-11-21 05:07:59 EST
Created attachment 827106 [details]
screenshot  on host
Comment 3 CongDong 2013-11-21 05:09:07 EST
Guest xrandr:
# xrandr
Screen 0: minimum 320 x 200, current 2080 x 1050, maximum 8192 x 8192
qxl-0 connected 1680x1050+0+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0* 
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   1064x795-0      0.1  
qxl-1 disconnected
   936x850-1       0.1  
   936x405-1       0.1  
qxl-2 disconnected
   1208x718-2      0.1  
qxl-3 connected 400x375+1680+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   976x664-3       0.1  
   400x375-3       0.1* 


Host xrandr:
# xrandr
Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+   74.9  
   1600x1000      60.0  
   1280x1024      75.0     72.0     60.0  
   1440x900       75.0     59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DVI-1 connected 1280x1024+1680+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1
Comment 4 Jonathon Jongsma 2014-02-27 17:22:12 EST
For what it's worth, this bug doesn't really apply to upstream virt-viewer anymore.  In upstream virt-viewer there is no longer a distinction between --full-screen and --full-screen=auto-conf.  --full-screen now behaves the same as --full-screen=auto-conf did.  

So if you try to reproduce these steps in new virt-viewer on a client machine with 2 monitors, the actual results of step 4 would be that display 4 would be disabled, and display 1 and 2 would be enabled and set to full-screen.

See https://www.redhat.com/archives/virt-tools-list/2014-February/msg00152.html for a more detailed discussion of fullscreen requirements in virt-viewer.
Comment 5 Marc-Andre Lureau 2014-03-12 16:27:44 EDT
adding dep on bug 1027381, which will clear this one when it's accepted
Comment 6 Marc-Andre Lureau 2014-06-04 10:52:57 EDT
rfe was accepted, rebase is 1097038

works as expected, please verify
Comment 8 CongDong 2014-06-05 02:32:37 EDT
I can reproduce this bug with virt-viewer-0.5.6-10.el6.x86_64

Verify with virt-viewer-0.6.0-4.el6.x86_64

1.Prepare a spice guest with qxl and spicevmc.
2.Start the guest,connect it with virt-viewer,enable display 1 and display 4(or 3).
# virt-viewer $guest
3.Close virt-viewer.
4.Use virt-viewer to connect the guest with option "-f"
# virt-viewer $guest -f
5.Repeat step2-step4 with display 1 and display 2

Result:
step4, only display 1 shows, but the resolution is same with the one when it is in windowed mode, another display is disabled. As comment 4, display 1 and display 2 should come out in fullscreen mode.

Step5, display 1 and display 2 are all in fullscreen mode in each monitor, but the resolution are not right, still keep the resolution when they in windowed mode. I think the resolution should same with the physical monitor.

As the result, ASSIGNED.
Comment 9 CongDong 2014-06-05 05:18:02 EDT
Please ignore comment 8.
May be something wrong with my env, I use another machine, don't get the problem, so I reinstall my machine, and re-test this, following is details:

I can reproduce this bug with virt-viewer-0.5.6-10.el6.x86_64

Verify with virt-viewer-0.6.0-4.el6.x86_64
1.Prepare a spice guest with qxl and spicevmc.
2.Start the guest,connect it with virt-viewer,enable display 1 and display 3.
# virt-viewer $guest
3.Close virt-viewer.
4.Use virt-viewer to connect the guest with option "-f"

Result:
1. after step4, two displays come out with fullscreen in each monitor.
   The two displays are display 1 and display 2, but display 2 doesn't have a wallpaper, it's all black background. And if I right click on display 2, the menu doesn't come out beside the mouse, the menu will show on display 1, beside the edge the two display.I'll add a screenshot to show the problem.

If I repeat step1 - step4 with display 1 and display 2 directly, don't have the problem.

So, as the result, keep ASSIGNED.
Comment 10 CongDong 2014-06-05 05:19:19 EDT
Created attachment 902465 [details]
display2 has black background and cannot hold the right click menu
Comment 11 CongDong 2014-06-05 05:21:00 EDT
Created attachment 902466 [details]
virt-viewer log with spice debug option for comment 9
Comment 12 Marc-Andre Lureau 2014-06-05 05:56:13 EDT
(In reply to CongDong from comment #11)
> Created attachment 902466 [details]
> virt-viewer log with spice debug option for comment 9

I don't see anything wrong in the log, and behaviour you describe looks like a guest issue.

Could you provide xrandr guest output after starting client with -f. thanks
Comment 13 CongDong 2014-06-05 06:06:35 EDT
After I run "xrandr", wallpaper shows on display 2, and the menu problem is disappeared.

Screen 0: minimum 320 x 200, current 3360 x 1050, maximum 8192 x 8192
qxl-0 connected 1680x1050+0+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0* 
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
qxl-1 connected 1680x1050+1680+0 0mm x 0mm
   1024x768       60.0 +
   2560x1600      60.0  
   2000x2000      60.0  
   2560x1440      60.0  
   2048x1536      60.0  
   1920x1440      60.0  
   1920x1200      60.0  
   1920x1080      60.0  
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       60.0  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       60.0  
   1152x870       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x760       60.0  
   1280x720       60.0  
   1024x600       60.0  
   960x640        60.0  
   832x624        60.0  
   800x600        60.0  
   800x480        60.0  
   640x480        60.0  
   1680x1050-1     0.1* 
qxl-2 disconnected
qxl-3 disconnected
Comment 14 Marc-Andre Lureau 2014-06-05 06:40:02 EDT
(In reply to CongDong from comment #13)
> After I run "xrandr", wallpaper shows on display 2, and the menu problem is
> disappeared.
> 

Hmm, most probably a vdagent bug then, still I can't reproduce.

If it works with a windows guest for you, I think the bug should be verified, and another bug should be opened for vdagent with more details on how to reproduce (and agent log)

thanks
Comment 15 CongDong 2014-06-06 04:50:46 EDT
(In reply to Marc-Andre Lureau from comment #14)
> (In reply to CongDong from comment #13)
> > After I run "xrandr", wallpaper shows on display 2, and the menu problem is
> > disappeared.
> > 
> 
> Hmm, most probably a vdagent bug then, still I can't reproduce.
> 
> If it works with a windows guest for you, I think the bug should be
> verified, and another bug should be opened for vdagent with more details on
> how to reproduce (and agent log)
> 
> thanks
Verify with virt-viewer-0.6.0-5.el6.x86_64
I re-test  win7 and windows xp guest, can get the right result.
Steps:
1. Prepare a win7(windows xp) guest, and configue it with 4 displays
2. Install qxl driver and spice-agent in guest
3. enable two displays of the geust, display 1 and display 3(or display 4)
4. # virt-viewer $vm -f
5. Click "Leave fullscreen"

Result:
Step 4, Two displays will be fullscreen in each monitor. 
Step 5, check the two displays, they are display 1 and display 2. Other displays are disabled.


So VERIFIED this bug, about the rhel guest problem I'll file a spice-vdagent bug later
Comment 16 errata-xmlrpc 2014-10-14 02:30:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.