Bug 1033089 - Don't install radvd.conf into /etc/tmpfiles.d/
Don't install radvd.conf into /etc/tmpfiles.d/
Status: CLOSED DUPLICATE of bug 984330
Product: Fedora
Classification: Fedora
Component: radvd (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Pavel Šimerda (pavlix)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 09:24 EST by Jiri Popelka
Modified: 2014-01-06 10:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 10:19:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sugested patch (1.04 KB, patch)
2013-11-21 09:24 EST, Jiri Popelka
no flags Details | Diff

  None (edit)
Description Jiri Popelka 2013-11-21 09:24:25 EST
Created attachment 827233 [details]
sugested patch

1) radvd installs radvd.conf into /etc/tmpfiles.d/

according to tmpfiles.d(5):
"Packages should install their configuration files in /usr/lib/. Files in /etc/
 are reserved for the local administrator, who may use this logic to override
 the configuration files installed by vendor packages."

You can use %{_tmpfilesdir} macro for that.

2) radvd owns /var/run/radvd/

according to
https://lists.fedoraproject.org/pipermail/devel-announce/2010-November/000726.html
"Many .spec files currently own subdirs of /var/run. These need to be
 updated to %ghost those dirs only, so that the automatic removal of
 these files/dirs on boot doesnt cause rpm to complain."
Comment 1 Jiri Popelka 2013-11-27 14:01:01 EST
(In reply to Jiri Popelka from comment #0)
> 2) radvd owns /var/run/radvd/
> 
> according to
> https://lists.fedoraproject.org/pipermail/devel-announce/2010-November/
> 000726.html
> "Many .spec files currently own subdirs of /var/run. These need to be
>  updated to %ghost those dirs only, so that the automatic removal of
>  these files/dirs on boot doesnt cause rpm to complain."

You can scratch this because according to
https://fedorahosted.org/fesco/ticket/525
it's actually better not to %ghost the directory
Comment 2 Pavel Šimerda (pavlix) 2014-01-06 10:19:29 EST

*** This bug has been marked as a duplicate of bug 984330 ***

Note You need to log in before you can comment on or make changes to this bug.