Bug 1033101 - RFE: rebase usbredir to latest upstream
RFE: rebase usbredir to latest upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: usbredir (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: 7.3
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
: FutureFeature, Rebase
Depends On: 1033088 1332712
Blocks: 976685 1033098 1033733
  Show dependency treegraph
 
Reported: 2013-11-21 09:46 EST by Hans de Goede
Modified: 2016-11-03 21:06 EDT (History)
11 users (show)

See Also:
Fixed In Version: usbredir-0.7.1-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:06:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-11-21 09:46:28 EST
usbredir in RHEL-7 currently is at usbredir-0.6, upgrading to at least 0.7 (which is not yet released) will be necessary to get full USB-3.0 support, which is necessary to add full USB-3 support for the usb-redirection code for qemu (bug 976685).
Comment 3 Marc-Andre Lureau 2014-07-01 14:41:42 EDT
Hans, are you still going to take care of this? thanks
Comment 4 Hans de Goede 2014-07-01 15:16:42 EDT
(In reply to Marc-Andre Lureau from comment #3)
> Hans, are you still going to take care of this? thanks

Yes I'm still, taking care of the libusb and usbredir packages. Note the libusb + usbredir rebase for usb-3 bulk stream support is not useful todo until the necessary kernel changes land.
Comment 5 Marc-Andre Lureau 2014-08-28 07:37:20 EDT
(In reply to Hans de Goede from comment #4)
> Yes I'm still, taking care of the libusb and usbredir packages. Note the
> libusb + usbredir rebase for usb-3 bulk stream support is not useful todo
> until the necessary kernel changes land.

is there a bug for that, to track the status? Is it expected in 7.1?
Comment 6 Hans de Goede 2014-08-28 07:58:08 EDT
(In reply to Marc-Andre Lureau from comment #5)
> is there a bug for that, to track the status? Is it expected in 7.1?

All the dependencies for USB-3.0 support are tracked in the RFE bug 976685 . The kernel bug is bug 1033088.
Comment 10 Marc-Andre Lureau 2015-04-22 06:05:05 EDT
moving to 7.3
Comment 12 Christophe Fergeau 2016-04-27 05:05:39 EDT
There seems to be some progress in the related kernel bug (rhbz#1033088), hopefully this will make it for 7.3.
Comment 13 Ademar Reis 2016-06-07 15:45:42 EDT
(In reply to Christophe Fergeau from comment #12)
> There seems to be some progress in the related kernel bug (rhbz#1033088),
> hopefully this will make it for 7.3.

It's POST now.
Comment 18 errata-xmlrpc 2016-11-03 21:06:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.