Bug 1033098 - RFE: add support for USB-3 bulk streams to usb-host and usb-redir redirection code
RFE: add support for USB-3 bulk streams to usb-host and usb-redir redirection...
Status: CLOSED DUPLICATE of bug 1033733
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
: FutureFeature
Depends On: 1033092 1033101
Blocks: 976685
  Show dependency treegraph
 
Reported: 2013-11-21 09:41 EST by Hans de Goede
Modified: 2013-12-02 12:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 02:45:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2013-11-21 09:41:58 EST
USB-3 has a new feature called bulk-streams. Bulk stream support is necessary to add full USB-3 support for the usb-redirection code for qemu.

Note bulk-streams support requires kernel and libusbx changes (for usb-host) and usbredir (for usb-redir) changes to be in place before it can be added to qemu.

My current qemu tree has patches to add it (tested with a locally build kernel, libusbx and usbredir):
http://cgit.freedesktop.org/~jwrdegoede/qemu/log/

Work to get this upstream is in progress, the kernel patches are scheduled to go into 3.14, once those are in place the rest can be pushed upstream pretty quickly.
Comment 2 Gerd Hoffmann 2013-11-22 02:14:09 EST
Planning for 7.1, imho not important enough to squeeze into 7.0 post-beta.
Comment 3 Hans de Goede 2013-11-22 04:02:17 EST
(In reply to Gerd Hoffmann from comment #2)
> Planning for 7.1, imho not important enough to squeeze into 7.0 post-beta.

Agreed, that was my intention all along, esp. since some bits are not upstream yet.
Comment 4 Gerd Hoffmann 2013-11-28 02:45:38 EST

*** This bug has been marked as a duplicate of bug 1033733 ***

Note You need to log in before you can comment on or make changes to this bug.