Bug 1033180 - [RFE][cinder]: Attach a single volume to multiple hosts [NEEDINFO]
Summary: [RFE][cinder]: Attach a single volume to multiple hosts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M2
: 14.0 (Rocky)
Assignee: Eric Harney
QA Contact: Tzach Shefi
URL: https://blueprints.launchpad.net/cind...
Whiteboard:
: 1033178 (view as bug list)
Depends On: 1033185 1623365 1625971
Blocks: 1230807 1281573 1339072 1442136 1476900 1478186 1496484 1761502 1022045 1213674 1613486 1624971 1661022 1694113 1746984
TreeView+ depends on / blocked
 
Reported: 2013-11-21 16:18 UTC by Stephen Gordon
Modified: 2019-10-14 14:27 UTC (History)
35 users (show)

Fixed In Version: openstack-cinder-13.0.0-0.20180710093321.64bebcd.el7ost
Doc Type: Technology Preview
Doc Text:
This release adds a Technology Preview of the ability to attach a volume to multiple hosts or servers simultaneously in both cinder and nova with read/write (RW) mode when this feature is supported by the back end driver. This feature addresses the clustered application workloads use case that typically requires active/active or active/standby scenarios.
Clone Of:
: 1624971 1661022 (view as bug list)
Environment:
Last Closed: 2019-01-11 11:47:00 UTC
tshefi: automate_bug+
ccopello: needinfo? (eharney)
jamsmith: needinfo? (eharney)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:0045 None None None 2019-01-11 11:48:10 UTC
OpenStack gerrit 85856 None None None Never
OpenStack gerrit 330285 None None None 2017-11-16 16:59:14 UTC
Red Hat Knowledge Base (Solution) 2529261 None None None 2016-08-15 18:01:07 UTC

Description Stephen Gordon 2013-11-21 16:18:40 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/cinder/+spec/multi-attach-volume.

Description:

Currently, the existing block storage (cinder) drivers allow for only a single volume to be attached to a single VM instance via iSCSI or Fibre Channel. To support a cluster, a single volume would need to be exported to multiple host. In this case vCenter will be used as an example, but any Hypervisor that supports clusters could require this functionality.

The Cinder etherpad https://etherpad.openstack.org/summit-havana-cinder-multi-attach-and-ro-volumes was present at the Havana Design summit resulted in the majority of the work to be completed in nova project. This work includes the looping mechanism that's responsible for calling the cinder drivers for each host in the cluster.

The Cinder work is not yet determined but would require minor work in tracking that a volume has multiple host attached to it.  Possibly changing the database entries for what volume is attached to a single host to a list of host. More work may be required once test have been ran to verify the data flow between multiple attach points.

This blueprint in for the limited cinder work that would be required from the following Nova blueprint: https://blueprints.launchpad.net/nova/+spec/fc-support-for-vcenter-driver

Specification URL (additional information):

None

Comment 1 Stephen Gordon 2013-11-27 20:35:49 UTC
*** Bug 1033178 has been marked as a duplicate of this bug. ***

Comment 8 Mike McCune 2016-03-28 22:33:16 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 12 Elise Gafford 2016-08-22 18:54:45 UTC
cinderclient 1.3.0 python-cinderclient-1.8.1-0.20160607191316.c955397.el7ost (which is in OSP10) is necessary but insufficient to address this bug. Per discussion, adding needinfo on eharney to clarify details of remaining work. Moving to RHOS 11, as this remaining work is by his estimation very unlikely to occur in 10.

Comment 15 Eric Harney 2016-09-14 14:27:27 UTC
Current multi-attach blueprint for Nova:
https://blueprints.launchpad.net/nova/+spec/multi-attach-volume

Nova Spec: https://review.openstack.org/#/c/304681/

Comment 16 Stephen Gordon 2016-09-15 07:25:10 UTC
(In reply to Eric Harney from comment #15)
> Current multi-attach blueprint for Nova:
> https://blueprints.launchpad.net/nova/+spec/multi-attach-volume
> 
> Nova Spec: https://review.openstack.org/#/c/304681/

I believe the downstream tracker for these is https://bugzilla.redhat.com/show_bug.cgi?id=1033185

Comment 18 Stephen Gordon 2016-12-23 15:33:54 UTC
*** Bug 1230807 has been marked as a duplicate of this bug. ***

Comment 33 Tzach Shefi 2018-08-29 11:35:28 UTC
Benny hit Nova issues bz1623365 while testing automation for this RFE.

Comment 38 Avi Avraham 2018-11-21 13:59:32 UTC
Verified according to test plan 
RPM package version :
python-cinder-13.0.1-0.20181013185427.31ff628.el7ost.noarch
python2-cinderclient-4.0.1-0.20180809133302.460229c.el7ost.noarch
puppet-cinder-13.3.1-0.20181013114719.25b1ba3.el7ost.noarch
openstack-cinder-13.0.1-0.20181013185427.31ff628.el7ost.noarch

Comment 42 errata-xmlrpc 2019-01-11 11:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:0045

Comment 43 James Smith 2019-01-18 21:10:32 UTC
This enhancement lets you attach a Block Storage volume to multiple hosts. 
You can attach a volume to multiple hosts or servers simultaneously in both the Block Storage (cinder) and Compute (nova) services with read/write (RW) mode. The feature addresses the clustered application workloads use case, which typically requires active/active or active/standby scenarios. The feature is intended for use with basic volume operations. Known limitations include encrypted volumes and migration.
Availability depends on back end support.


Note You need to log in before you can comment on or make changes to this bug.