Bug 103360 - redhat-logviewer fails to start without WARNINGWORDS in config file
redhat-logviewer fails to start without WARNINGWORDS in config file
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-logviewer (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-29 06:39 EDT by Daniel Malmgren
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.9.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 22:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2003-08-29 06:39:15 EDT
Description of problem:
I can't seem to start redhat-logviewer.

Version-Release number of selected component (if applicable):
0.9.2-2

How reproducible:
Happens every time.

Steps to Reproduce:
1. Start the program
    
Actual results:
[root@Datorn rpm]# redhat-logviewer
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 80, in ?
    LogViewerGui.LogViewerGui(width,height, allowConfigChanges,
configFile,initialView)
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 162, in __init__
    self.initial_read_of_file()
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 343, in
initial_read_of_file
    logClassInstance = LogFileClass.LogFileClass(key)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 74, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 130, in read_log
    if alert == 0 and len(LogViewerGui.warningWords[0]) > 0:
IndexError: list index out of range

Additional info:
I don't think this is really a redhat-logviewer bug, since I get a very similar
result from the new redhat-config-boot. Don't know where else to report it though.

Versions of some installed rpm's:
pygtk2-1.99.16-10
python-2.2.3-3
usermode-1.68-2
Comment 1 Brian L Scipioni 2003-09-08 06:57:32 EDT
I get nearly the same bug - my error output from the cmdline:
redhat-logviewer
unable to translate from iso-8859-1 utf-8
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 30, in ?
    import LogViewerGui
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 122, in ?
    sysClass = LogFileClass.LogFileClass("SYSLOG")
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 69, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 119, in read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 117, in
insert_into_buffer_at_offset
    self.insert(iter, line, -1)
TypeError: GtkTextBuffer.insert() argument 2 must be string without null bytes,
not str
Comment 2 Tammy Fox 2003-09-08 16:36:55 EDT
The second traceback is not the same as the first. Brian, please file a
different bug and attached your /etc/sysconfig/redhat-logviewer file. 

Daniel, please attach your /etc/sysconfig/redhat-logviewer file to this bug.
Comment 3 Daniel Malmgren 2003-09-09 02:39:01 EDT
Hmmm...

When I was about to attach the /etc/sysconfig/redhat-logviewer I discovered that
I also had a /etc/sysconfig/redhat-logviewer.rpmnew. Renamed that one to
redhat-logviewer and now it works.

Seems the difference between the files is that the line with WARNINGWORDS
doesn't exist in the old file. So now you know what was wrong. Maybe the program
should be able to operate without that line though?
Comment 4 Tammy Fox 2003-09-09 10:27:15 EDT
Yes. It should start without that line. I will fix it and get back to you.
Thanks for the report.
Comment 5 Tammy Fox 2003-09-10 22:28:27 EDT
Version 0.9.3-2 should appear in Rawhide shortly to fix this. I also fixed it so
it does not traceback of ALERTWORDS= doesn't exist in the prefs file.

Note You need to log in before you can comment on or make changes to this bug.