Bug 103363 - gedit's libgnomeui and eel2 version dependencies need updating
gedit's libgnomeui and eel2 version dependencies need updating
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gedit (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-29 08:17 EDT by Jens Petersen
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-07 15:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2003-08-29 08:17:27 EDT
Description of problem:
When I updated to gedit-2.3.5-1, gedit wouldn't start until I also
updated libgnomeui and eel2 (and a batch of libgnomeui deps).
Since it is not very obvious which lib the missing symbol is from,
it is not so easy to fix this problem.

How reproducible:
Every time.

Steps to Reproduce:
1. Update to latest gedit package from a Shrike install say.
2. Run gedit
    
Actual results:
gedit: relocation error: gedit: undefined symbol: gnome_authentication_manager_init

Expected results:
gedit to run normally, not install because of missing deps.
gedit should probably require libgnomeui >= 2.3.6 and eel2 >= 2.3.9
or something simular.

Additional info:
Updated {libgnomeui,libbonobo,ORBit2,libIDL,linc,eel2} fixed it.
The eel2 dep suggestion comes, because before updating eel2, I got
% gedit
gedit: relocation error: gedit: undefined symbol: eel_input_event_box_new
Comment 1 Owen Taylor 2003-10-07 15:23:30 EDT
* Tue Oct  7 2003 Owen Taylor <otaylor@redhat.com> 1:2.4.0-2
- Add versioned Requires on eel2, libgnomeui (#103363, Jens Petersen)

Note You need to log in before you can comment on or make changes to this bug.