Bug 103365 - (TBe4037beb) redhat-control-network:340:hydrateProfiles:AttributeError: 'NoneType' object has no attribute 'hide'
redhat-control-network:340:hydrateProfiles:AttributeError: 'NoneType' object ...
Status: CLOSED DUPLICATE of bug 109603
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-network (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
DELL SHOULDFIX for Taroon U1
:
: 104147 (view as bug list)
Depends On:
Blocks: 106712
  Show dependency treegraph
 
Reported: 2003-08-29 08:53 EDT by Chan Seng Loong
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception.txt from Bug 104147 (1.34 KB, text/plain)
2003-11-04 10:23 EST, Larry Troan
no flags Details

  None (edit)
Description Chan Seng Loong 2003-08-29 08:53:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
the configuration window shutdown and cuase lost control over the mouse

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1.just try to reconfigure the network
2.
3.
    

Additional info:

Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 224, in on_configureButton_clicked
    self.hydrateProfiles(refresh = TRUE)
  File "/usr/bin/redhat-control-network", line 340, in hydrateProfiles
    self.xml.get_widget('profileFrame').hide()
AttributeError: 'NoneType' object has no attribute 'hide'

Local variables in innermost frame:
profilelist: ProfileList.default.HostsList.1.IP=127.0.0.1
ProfileList.default.HostsList.1.Hostname=AMD1500Mhz
ProfileList.default.HostsList.1.AliasList.1=localhost.localdomain
ProfileList.default.HostsList.1.AliasList.2=localhost
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=202.188.1.5
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=202.188.0.132
ProfileList.default.DNS.Hostname=AMD1500Mhz
ProfileList.default.DNS.TertiaryDNS=202.188.0.133
ProfileList.default.Active=true
ProfileList.default.ProfileName=default

self: <__main__.mainDialog instance at 0x85664e4>
omenu: None
refresh: 1
Comment 1 Harald Hoyer 2003-08-29 09:01:53 EDT
huh? do you have more than one neat-control.glade??
you might check this by pasting in here the output of:
$ locate neat-control.glade
Comment 2 Harald Hoyer 2003-09-11 05:27:40 EDT
*** Bug 104147 has been marked as a duplicate of this bug. ***
Comment 3 Larry Troan 2003-09-16 11:53:52 EDT
Per DUP Bug 104147 (private) (ref: Issue Tracker 27488 opened as sev 2)... 
Also a problem on Taroon Beta2.
Comment 4 Larry Troan 2003-10-16 10:04:54 EDT
Dell SHOULDFIX for RHEL3 Update1. Adding SHOULDFIX blocker bug.
(Note that Taroon BUG was closed as DUP of this RHL9 Bug.)

Waiting for output of $ locate neat-control.glade per comment #1 above.....
Comment 7 Larry Troan 2003-11-04 10:23:55 EST
Created attachment 95709 [details]
exception.txt from Bug 104147
Comment 11 Harald Hoyer 2004-06-04 06:10:50 EDT
maybe configure was pressed in r-control-network, this started
r-c-network and then the r-control-network window was closed before
r-c-network...

Comment 12 Harald Hoyer 2004-06-04 08:33:05 EDT

*** This bug has been marked as a duplicate of 109603 ***
Comment 13 Red Hat Bugzilla 2006-02-21 13:58:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.