Bug 109603 (TBd50ddb08) - TB redhat-control-network:341:hydrateProfiles:AttributeError: 'NoneType' object has no attribute 'hide'
Summary: TB redhat-control-network:341:hydrateProfiles:AttributeError: 'NoneType' obje...
Status: CLOSED CURRENTRELEASE
Alias: TBd50ddb08
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: TBe4037beb 116060 117655 119899 126651 245520 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-10 02:41 UTC by Adam Jenkins
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-08 16:14:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file created (1.12 KB, application/octet-stream)
2003-11-10 02:44 UTC, Adam Jenkins
no flags Details

Description Adam Jenkins 2003-11-10 02:41:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I can't remember exactly what I did before this happened sorry. 
Generally, I was trying to add a new modem connection, using a modem
type I specified myself as /dev/ttyS0 (modem wasn't detected, it's an
AOpen external 56k) and I was trying the wrong password.
I also have a NIC in the machine configured with a static IP and not
being used, which was active before adding the modem connection.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10.1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I think I'd just clicked to close the Network Device Control or
Configuration dialog window.  If I do that again, I don't get the
error.  Will try and reproduce it some more.

Additional info:

Comment 1 Adam Jenkins 2003-11-10 02:44:29 UTC
Created attachment 95863 [details]
dump file created

This is probably much more helpful than my description!

Comment 2 Harald Hoyer 2003-11-25 15:17:26 UTC
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 224, in
on_configureButton_clicked
    self.hydrateProfiles(refresh = TRUE)
  File "/usr/bin/redhat-control-network", line 341, in hydrateProfiles
    self.xml.get_widget('profileFrame').hide()
AttributeError: 'NoneType' object has no attribute 'hide'

Local variables in innermost frame:
profilelist: ProfileList.default.HostsList.1.IP=127.0.0.1
ProfileList.default.HostsList.1.Hostname=imogen1
ProfileList.default.HostsList.1.AliasList.1=localhost.localdomain
ProfileList.default.HostsList.1.AliasList.2=localhost
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=
ProfileList.default.DNS.Hostname=imogen1
ProfileList.default.DNS.TertiaryDNS=
ProfileList.default.Active=true
ProfileList.default.ProfileName=default

self: <__main__.mainDialog instance at 0x902a114>
omenu: None
refresh: 1


Comment 3 Harald Hoyer 2003-11-25 15:18:43 UTC
can you please verify the correct installation of redhat-config-network:
$ rpm -V redhat-config-network && echo OK

Comment 4 Harald Hoyer 2004-02-18 09:14:57 UTC
*** Bug 116060 has been marked as a duplicate of this bug. ***

Comment 5 Jason Knight 2004-02-19 00:44:36 UTC
Odd, it tells me that I dont have the package installed yet it runs
fine.  rpm -V redhat-config-network && echo OK
package redhat-config-network is not installed


Comment 6 Harald Hoyer 2004-02-19 09:11:26 UTC
well, then s.th. with the installation went wrong!

Comment 7 Harald Hoyer 2004-03-08 13:02:50 UTC
*** Bug 117655 has been marked as a duplicate of this bug. ***

Comment 8 Adam Jenkins 2004-03-09 00:17:09 UTC
I'd check for you but I don't have Fedora installed anymore sorry.

Comment 9 Chris Jones 2004-03-30 20:58:31 UTC
I have just managed to repeat this error (I think). Please see
following  crash dump listing:-

Component: redhat-config-network
Version: 1.3.10
Summary: TBd50ddb08
redhat-control-network:341:hydrateProfiles:AttributeError: 'NoneType'
object has no attribute 'hide'
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 224, in
on_configureButton_clicked
    self.hydrateProfiles(refresh = TRUE)
  File "/usr/bin/redhat-control-network", line 341, in hydrateProfiles
    self.xml.get_widget('profileFrame').hide()
AttributeError: 'NoneType' object has no attribute 'hide'

Local variables in innermost frame:
profilelist: ProfileList.default.HostsList.1.IP=192.168.0.3
ProfileList.default.HostsList.1.Hostname=bilbo.stow-jones.co.uk
ProfileList.default.HostsList.1.AliasList.1=bilbo
ProfileList.default.HostsList.2.IP=192.168.0.2
ProfileList.default.HostsList.2.Hostname=gandalf
ProfileList.default.HostsList.2.AliasList.1=gandalf
ProfileList.default.HostsList.3.IP=192.168.0.3
ProfileList.default.HostsList.3.Hostname=stow-jones
ProfileList.default.HostsList.3.AliasList.1=bilbo
ProfileList.default.HostsList.4.IP=127.0.0.1
ProfileList.default.HostsList.4.Hostname=localhost.localdomain
ProfileList.default.HostsList.4.AliasList.1=localhost
ProfileList.default.HostsList.5.IP=192.168.0.3
ProfileList.default.HostsList.5.Hostname=stow-jones.int.uk
ProfileList.default.HostsList.5.AliasList.1=stow-jones
ProfileList.default.ActiveDevices.1=eth0
ProfileList.default.DNS.SecondaryDNS=212.23.3.1
ProfileList.default.DNS.SearchList.1=zen.co.uk
ProfileList.default.DNS.Domainname=
ProfileList.default.DNS.PrimaryDNS=212.23.8.1
ProfileList.default.DNS.Hostname=localhost.localdomain
ProfileList.default.DNS.TertiaryDNS=
ProfileList.default.Active=true
ProfileList.default.ProfileName=default

self: <__main__.mainDialog instance at 0xa1da9c4>
omenu: None
refresh: 1


I closed "Network Device Control" before "Network Configuration" by
selecting the "X" box in the top right corner. Then closed the
"Network Configuration" menu by selecting "File/Quit". At this point
the crash dump was generated.

This error is consistantly reproducible with 1.3.10 of
redhat-config-network

Comment 10 Harald Hoyer 2004-04-05 08:38:54 UTC
*** Bug 119899 has been marked as a duplicate of this bug. ***

Comment 11 Harald Hoyer 2004-06-04 12:33:08 UTC
*** Bug 103365 has been marked as a duplicate of this bug. ***

Comment 12 Harald Hoyer 2004-06-24 11:20:24 UTC
*** Bug 126651 has been marked as a duplicate of this bug. ***

Comment 13 Christopher Beland 2004-06-27 19:57:21 UTC
I apparently experienced this crash with 1.3.16-1 of
system-control-network (Fedora Core 2).  (I think I missed seeing this
bug the first time around because the name of the package changed.)


Comment 14 Harald Hoyer 2005-07-08 16:14:59 UTC
should be fixed in current releases

Comment 15 Harald Hoyer 2007-06-27 10:28:59 UTC
*** Bug 245520 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.