Bug 1034062 - Values for port offset configuration are doubled in domain's host files.
Summary: Values for port offset configuration are doubled in domain's host files.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER3
: EAP 6.3.0
Assignee: Miles Tjandrawidjaja
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-25 08:12 UTC by Petr Kremensky
Modified: 2014-09-03 04:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A bug that caused automatic port offsets to be doubled when set using the `Configure an offset for all default port bindings` option has been corrected in this release.
Clone Of:
Environment:
Last Closed: 2014-06-28 15:44:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Kremensky 2013-11-25 08:12:37 UTC
Description of problem:
 Port offset modifier is doubled to the value selected by user. 

Version-Release number of selected component (if applicable):
 EAP 6.2.0.CR3

How reproducible:
 Always

Steps to Reproduce:
 1. Start the gui installation, go to Socket Binding screen using default values.
 2. Select to "Configure an offset for all default port bindings".
 3. Select "+100 offset" option (you can choose arbitrary value, result will be the same)
 4. Finish the installation. Go to $JBOSS_HOME/domain/configuration/ and observer host files.

Actual results:
Port offset 200 is used for most of values in host.xml files.

Expected results:
Port offset 100 is used as selected by user.

Additional info:
host.xml
 - management native port offset is doubled
 - management http port offset is doubled
 - server offsets are fine
host-master.xml
 - management native port offset is doubled
 - management http port offset is doubled
host-slave.xml
 - management native port offset is doubled
 - domain master port is fine
 - server offsets are missing (covered by BZ1034057)

Comment 1 Miles Tjandrawidjaja 2013-11-25 17:29:31 UTC
Ports will not longer be doubled by offset.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=439c5e594ba2d0dbd1004a2617aa6419e704a6c1

Comment 2 Petr Kremensky 2014-04-18 08:09:57 UTC
This is still a velid issue for EAP 6.3.0.ER1 installer.
 - set automatic port offset to +1
 - open jboss-eap-6.3/domain/configuration/host.xml file
Actual 
        <management-interfaces>
            <native-interface security-realm="ManagementRealm">
              <socket interface="management" port="${jboss.management.native.port:10001}"/>
            </native-interface>
            <http-interface security-realm="ManagementRealm">
              <socket interface="management" port="${jboss.management.http.port:9992}"/>
            </http-interface>
        </management-interfaces>
Expected
        <management-interfaces>
            <native-interface security-realm="ManagementRealm">
              <socket interface="management" port="${jboss.management.native.port:10000}"/>
            </native-interface>
            <http-interface security-realm="ManagementRealm">
              <socket interface="management" port="${jboss.management.http.port:9991}"/>
            </http-interface>
        </management-interfaces>

Comment 3 Miles Tjandrawidjaja 2014-04-28 15:27:34 UTC
This has been resolved in ER2.

Comment 4 Petr Kremensky 2014-05-02 13:04:53 UTC
Verified on EAP 6.3.0.ER2 installer.

Comment 5 sgilda 2014-05-12 19:50:14 UTC
Changed <guilabel></guilabel> tag in Doc Text to ticks (`) to fix Bug 1096865

Comment 6 Scott Mumford 2014-05-13 22:18:16 UTC
marking for exclusion from release notes as per bug 1097065.

Comment 7 Petr Kremensky 2014-07-09 07:28:14 UTC
Re-adding the doc_text flag as it was removed due to beta RN.


Note You need to log in before you can comment on or make changes to this bug.