Bug 103423 - redhat-config-network exception during CANCEL of modem dial-up (happens every time)
redhat-config-network exception during CANCEL of modem dial-up (happens every...
Status: CLOSED DUPLICATE of bug 103421
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-29 19:41 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-29 19:41:23 EDT
Description of problem:

In the Network Device Control applet in RH9, open it up in order to dial the
modem. If you activate the modem (ppp0 in my case), a new window pops up
actually during the dialing process (BTW it'd be good if it actually logged the
handshaking stuff in there like the MS one!).

Anyway, at the bottom of the window is the CANCEL button for cancelling the
modem dialup that is in process. If I click on this, not only does the dialling
process NOT halt but continue normally and connect, but on pressing CANCEL I
ALWAYS get the following exception:

*********************************EXCEPTION OCCURED**************

Component: redhat-config-network
Version: 1.2.15
Summary: TB79414994 GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1]
Operation not permitted
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 184, in on_activateButton_clicked
    (ret, msg) = dev.activate()
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 376, in activate
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 420, in generic_run_dialog
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 523, in gui_run_dialog
OSError: [Errno 1] Operation not permitted

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x868086c>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x8680a34>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x8680b2c>
cancelbutton: <gtk.Button object (GtkButton) at 0x86809ec>
command: /usr/sbin/usernetctl
argv: ['/usr/sbin/usernetctl', 'ppp0', 'up']
searchPath: 0
label: Activating network device Tiscali, please wait...
lbl: <gtk.Label object (GtkLabel) at 0x868075c>
select: <module 'select' from '/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x866620c>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x86847dc>
errlabel: Cannot activate network device Tiscali!

fdout: []
root: /
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0x8673664>
write: 4
read: 3
s: 1
childpid: 1780
closefd: -1
dialog: None
rc: 
title: redhat-config-network:

Network device activating...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x86809bc>

*************************************************************


Version-Release number of selected component (if applicable):

redhat-config-network 1.2.15

How reproducible:

To reproduce, click cancel during the modem dial up process in the window that
always appears during it.

Steps to Reproduce:
1.Open Network device Control applet
2.Dial up modem
3.Click cancel button during modem dial up "et volia!"
    
Actual results:

Results of this described Afore


Expected results:

Basically, the modem should halt the dialup process (snappily too pls, the whole
shabang seems very sluggish compared to dial up networking in bindows.) 

Additional info:
Comment 1 Harald Hoyer 2003-09-01 11:06:45 EDT

*** This bug has been marked as a duplicate of 103421 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.