Bug 103421 - (TB79414994) TB GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1] Operation not permitted
TB GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1] Operation not permi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
: 103423 104783 106637 106841 111181 114361 128664 (view as bug list)
Depends On:
Blocks: 111252
  Show dependency treegraph
 
Reported: 2003-08-29 18:31 EDT by Need Real Name
Modified: 2007-04-18 12:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: 1.3.13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-17 09:02:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash dump information provided in error window (2.03 KB, text/plain)
2003-08-29 18:33 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2003-08-29 18:31:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I use a 56K V92 HCF PCI modem for Internet access via a dial-up connection.
Being essentially a Winmodem, I had to obtain special drivers for use in Linux.
I downloaded a beta driver from Linuxant (http://www.linuxant.com), but I do not
see why this problem should relate to these drivers.

Occasionally when trying to connect, it is obvious that the handshake procedure
is not working properly by the noises coming from the modem's internal speaker,
so I disconnect and try again. However, clicking the 'Cancel' button in the
'Activating network device, please wait' dialogue box immediately brings up a
window entitled 'Exception Occurred', with the crash dump information in it and
the option of saving it to a file. The modem does not disconnect as expected,
and keeps retrying the connection even after I have closed the error window by
clicking the 'Quit' button (which also causes the Network Device Control window
to close).

To stop the modem from repeatedly attempting a connection, I have to re-open
Network Device Control (redhat-config-network) and click the 'Deactivate'
button. This will successfully deactivate the modem, but my point is that using
the intended method for cancelling a connection (the 'Cancel' button that is
present in the dialogue box that appears while connecting) causes an error.

It is a random occurrence that a connection is not proceeding correctly,
however, clicking the 'Cancel' button as described above will produce the error
message even if the dial-up handshaking procedure is working correctly.


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1. Open the Network Device Control application (redhat-config-network) - I use a
desktop link icon.
2. Select the network device from the list box and click 'Activate'.
3. In the window that appears (bearing the text 'Activating network device
<NAME>, please wait...'), click 'Cancel'.
4. Unhandled exception error message appears.


Actual Results:  A window entitled 'Exception Occurred' appeared, bearing the text:
"An unhandled exception error has occurred. This is most likely a bug. Please
save the crash dump and file a detailed bug report against redhat-config-network
at https://bugzilla.redhat.com/bugzilla"
Below that, the crash dump information, with 'Debug', 'Save to file' and 'Quit'
buttons at the bottom. The first time I received this error, I clicked 'Save to
file' to capture the crash dump info (which is attached to this bug report); on
subsequent occurrences I have clicked the 'Quit' button, which closes the window
and terminates the Network Device Control application and all associated windows
(e.g. the 'Activating network device' dialogue).

Expected Results:  On clicking the 'Cancel' button (step 3), I would have
expected my modem to disconnect (which would be evident from the ceasing of
noises from the modem's internal speaker), and the 'Activating network device'
window to disappear, as it does upon completion of a successful connection.

Additional Info:  The crash dump info is attached to this report.
Comment 1 Need Real Name 2003-08-29 18:33:51 EDT
Created attachment 94080 [details]
Crash dump information provided in error window

This attachment is the file that was generated by clicking the 'Save to file'
button in the error window.
Comment 2 Harald Hoyer 2003-09-01 11:06:08 EDT
thx for the report..
Comment 3 Harald Hoyer 2003-09-01 11:06:47 EDT
*** Bug 103423 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2003-10-09 10:59:33 EDT
*** Bug 106637 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2003-10-13 06:25:44 EDT
*** Bug 106841 has been marked as a duplicate of this bug. ***
Comment 6 Harald Hoyer 2003-10-28 05:26:09 EST
*** Bug 104783 has been marked as a duplicate of this bug. ***
Comment 7 Colin Wheat 2003-11-01 14:10:15 EST
I see the same exception on two rh9 pc's with all upg rpms (~
2003-10-20) applied, but from redhat-control-network, not from
redhat-config-network.

Conditions are: occurs for redhat-control-network when canceling a
modem connection attempt, when logged in as other than the root user.
If logged in as root cancel works without problem. Note that
redhat-config-network cancels a modem connection attempt without
problem, with either root login, or as other user (and prompting for
root pw).

Comment 8 Harald Hoyer 2004-01-29 09:33:30 EST
*** Bug 111181 has been marked as a duplicate of this bug. ***
Comment 9 Harald Hoyer 2004-01-29 10:00:54 EST
*** Bug 114361 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2004-07-28 03:20:30 EDT
*** Bug 128664 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.