Bug 103488 - up2date never closes proxy connection
up2date never closes proxy connection
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: rhnlib (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-01 00:44 EDT by Rik van Riel
Modified: 2007-04-18 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:28:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2003-09-01 00:44:03 EDT
Description of problem:

After a while the up2date process gets stuck, because it cannot open any more
files. The reason for this is that it doesn't close sockets with a connection to
the squid proxy on my network.

Raising the ulimit to 4000 didn't help one bit, up2date simply went to the point
of having 3999 open files and refused to go any further.

Version-Release number of selected component (if applicable):

up2date-3.9.18-2

How reproducible:

1. Install Severn B1
2. Try upgrading to severn-upgrades
3. Fail miserably

Expected results:

Proxy connections should be closed after the package is downloaded. Up2date
should work.

Additional info:
Comment 1 Adrian Likins 2003-09-02 15:01:03 EDT
misa is taking a look at this, since it's presumably a rhnlib
bug
Comment 2 Mihai Ibanescu 2003-09-02 19:05:26 EDT
Having troubles finding the B1 tree - will resume tomorrow.
Comment 3 Mihai Ibanescu 2003-09-02 19:28:32 EDT
OK, reproduced it.
Comment 4 Mihai Ibanescu 2003-09-02 20:02:14 EDT
Fixed in rhnlib 1.3-8 and higher.
Comment 5 Mihai Ibanescu 2003-09-02 20:15:57 EDT
Hmm, investigating some more.
Comment 6 Mihai Ibanescu 2003-09-03 10:31:55 EDT
OK, fixed in rhnlib-1.3-10 and later
Rik, can you please install rhnlib-1.3-11 and check if the leak is still there?
Comment 7 Bill Nottingham 2006-08-04 16:28:31 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.