Bug 1035004 - Quicklauncher icons missing
Summary: Quicklauncher icons missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxpanel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F20FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-11-26 20:26 UTC by Christoph Wickert
Modified: 2013-12-10 06:57 UTC (History)
2 users (show)

Fixed In Version: lxpanel-0.6.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of: 1028063
Environment:
Last Closed: 2013-12-10 06:57:19 UTC


Attachments (Terms of Use)

Description Christoph Wickert 2013-11-26 20:26:59 UTC
+++ This bug was initially created as a clone of Bug #1028063 +++

Description of problem:
In the F20 LXDE livecd, the icons for file manager, and terminal in lxpanel's quicklaunch bar are not working. Clicking them does not launch pcmanfm or lxterminal and the and the icon is just the gtk stock icon.

This is due to the "de-vendorization". /usr/share/lxpanel/profle/LXDE/panels/panel still contains "fedora-pcmanfm.desktop" and "fedora-lxterminal.desktop" instead of just "pcmanfm.desktop" and "lxterminal.desktop"

Version-Release number of selected component (if applicable):
lxde-common-0.5.5-0.7.20110328git87c368d7.fc20.noarch

--- Additional comment from Christoph Wickert on 2013-11-26 15:25:37 EST ---

Fix is on the way.

I'd like to request a Freeze Exception as this bug
a) breaks https://fedoraproject.org/wiki/QA:Testcase_desktop_panel_advanced: "All elements of the default panel configuration should work as intended in typical interaction" for the LXDE spin.
and 
b) is trivial to fix.

Comment 1 Christoph Wickert 2013-11-26 20:28:40 UTC
Note: This clone is against lxpanel, not lxde-common. One is for the LXDE spin, the other for standards installs.

Comment 2 Adam Williamson 2013-11-26 20:52:46 UTC
I've seen this bug, it looks kinda crappy for LXDE live users. +1 FE.

Comment 3 Fedora Update System 2013-11-26 20:58:26 UTC
lxpanel-0.6.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lxpanel-0.6.1-2.fc20

Comment 4 Fedora Update System 2013-11-27 16:14:49 UTC
Package lxpanel-0.6.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.6.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22291/lxpanel-0.6.1-2.fc20
then log in and leave karma (feedback).

Comment 5 Adam Williamson 2013-11-27 19:32:43 UTC
Discussed at 2013-11-27 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-11-27/f20-blocker-review-3.2013-11-27-17.01.log.txt . Accepted as a freeze exception issue - polish problem in a shipped desktop, can't be fully fixed post-release as it affects lives.

Comment 6 Fedora Update System 2013-12-01 17:40:58 UTC
Package lxpanel-0.6.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.6.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22291/lxpanel-0.6.1-3.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-12-03 02:45:25 UTC
lxpanel-0.6.1-3.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21536/lxpanel-0.6.1-3.fc20,lxlauncher-0.2.2-4.fc20,pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20,libfm-1.1.2.2-3.fc20,menu-cache-0.5.1-1.fc20

Comment 8 Fedora Update System 2013-12-10 06:57:19 UTC
lxpanel-0.6.1-3.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.