Bug 103518 - dvorak keymap fails in virtual consoles
Summary: dvorak keymap fails in virtual consoles
Status: CLOSED DUPLICATE of bug 90562
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kbd   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-01 17:22 UTC by Paul Morgan
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Morgan 2003-09-01 17:22:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Dvorak keyboard layout does not work in virtual consoles.

The dvorak layout works fine in X (default RH Bluecurve - gnome metacity), but
the virtual consoles do not load the correct layout.

In a virtual console while logged in as root or non-root user, running `loadkeys
dvorak` results in the following output:
Loading //lib/kbd/keymaps/i386/dvorak
input in flex scanner failed

Version-Release number of selected component (if applicable):
kbd-1.08-6

How reproducible:
Always

Steps to Reproduce:
Edit /etc/sysconfig/keyboard as follows:
KEYBOARDTYPE="pc"
KEYTABLE="dvorak"

init 6

Actual Results:  During init, the following messages are logged:
Sep  1 09:22:39 vaio keytable:
Sep  1 09:22:39 vaio keytable: Loading system font:
Sep  1 09:22:39 vaio keytable:
Sep  1 09:22:39 vaio rc: Starting keytable:  failed


Expected Results:  Keyboard layout should load correctly for virtual consoles.

Additional info:

Dvorak layout within virtual consoles worked in RH8, but not RH9 and not Severn.

Workaround: ANSI-dvorak layout works fine in both X and virtual consoles under
Severn. I have not tested the dvorak-l (left) or dvorak-r (right) layouts.

Comment 1 Paul Morgan 2003-09-01 19:08:28 UTC

*** This bug has been marked as a duplicate of 90562 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.