Bug 1035238 - [RFE] Support for moving hosts to sleep when using Power Saving policy
Summary: [RFE] Support for moving hosts to sleep when using Power Saving policy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Martin Sivák
QA Contact: Artyom
URL:
Whiteboard: sla
: 865794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-27 11:08 UTC by Martin Sivák
Modified: 2014-12-15 12:52 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 15:04:55 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22376 None None None Never
Red Hat Bugzilla 516905 None None None 2019-02-01 02:57:35 UTC

Internal Links: 516905

Description Martin Sivák 2013-11-27 11:08:05 UTC
This feature should allow the engine to put an empty host to sleep and wake it up again using Wake On LAN when needed. The decision for those actions should be governed by the currently used Cluster policy.

Comment 1 Itamar Heim 2013-12-18 12:52:49 UTC
sleep sounds like S3 state, do we really intend to S3 and not S5 (shutdown)?
will this be based on WOL or power management?

Comment 2 Martin Sivák 2013-12-18 14:05:16 UTC
We will use S5 in the first version and we will use ssh and power management to get there.

Sleep is something that would make the host start up quickly when we need it, but it is also a bit problematic when we talk about server machines.

The current design is described on the feature page: http://www.ovirt.org/Features/HostPowerManagementPolicy

Comment 3 Doron Fediuck 2014-01-05 12:57:07 UTC
*** Bug 865794 has been marked as a duplicate of this bug. ***

Comment 4 Pablo Iranzo Gómez 2014-01-07 12:06:07 UTC
Martin, for recent HP machines, boot can take ~ 15 minutes, so ruling out already 'starting' hosts for that period of time could be useful for avoiding starting hosts.

When working with different hosts, using bogomips as a rule could be helpful  but will bring another RFE: tune the hosts up/down to be more power efficient:

Having the biggest host to just run 1 small VM will not be the best option, so having some kind of 'measure' of how big a VM is and how powerful the host is, could help to leverage them.

Thanks!

Comment 5 Artyom 2014-03-09 09:19:57 UTC
Verified on av2
Verified on tcms plan

Comment 6 Sandro Bonazzola 2014-03-31 15:04:55 UTC
This is an automated message: moving to Closed CURRENT_RELEASE since oVirt 3.4.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.