Bug 1035448 - all screens turn off when docking
all screens turn off when docking
Status: CLOSED DUPLICATE of bug 1036974
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-27 14:48 EST by Havoc Pennington
Modified: 2013-12-04 10:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-04 10:49:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2013-11-27 14:48:05 EST
I have a thinkpad T440s and matching dock. With a monitor connected to the dock, if I dock the laptop then the laptop screen blanks and the monitor does not come on, so I have zero screens. I'm not sure whether anything else is happening since I can't see it :-)

I don't know where the logic to handle this lives, so picking gnome-shell and will let someone with a clue fix the component.

Freshly-installed (not upgraded) Fedora 20 beta.

Tell me which logs are useful if I should collect any.

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

vendor_id       : GenuineIntel
cpu family      : 6
model           : 69
model name      : Intel(R) Core(TM) i7-4600U CPU @ 2.10GHz

Intel graphics are used, there's no discrete GPU.

How reproducible:

With laptop lid open, and external monitor attached to dock, drop laptop into the dock. Laptop panel turns off (OK) but external monitor does not come on (not OK).

With external monitor NOT connected, laptop panel does NOT turn off, which is desired. The problem is just that when an external monitor is connected, one of the screens needs to be left on.

It doesn't seem to matter whether the external monitor is powered on, only whether it is plugged into the dock. If it's plugged in then the laptop panel blanks even if the external monitor is powered off.
Comment 1 Ferry Huberts 2013-12-04 10:36:32 EST
IMHO this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1036974
Comment 2 Havoc Pennington 2013-12-04 10:49:36 EST
Agreed, that looks like the same thing. I couldn't tell it was frozen without getting fancy (since: no screen). The action is on the fd.org bug: https://bugs.freedesktop.org/show_bug.cgi?id=71267

*** This bug has been marked as a duplicate of bug 1036974 ***

Note You need to log in before you can comment on or make changes to this bug.