Bug 1036974 - Thinkpad t440s freezes in Ultra Dock with external monitors
Summary: Thinkpad t440s freezes in Ultra Dock with external monitors
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-module-thinkpad
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jason Carpenter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1035448 (view as bug list)
Depends On:
Blocks: 1247240
TreeView+ depends on / blocked
 
Reported: 2013-12-03 02:20 UTC by Eric Floehr
Modified: 2015-07-27 15:43 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1247240 (view as bug list)
Environment:
Last Closed: 2014-02-14 16:35:48 UTC


Attachments (Terms of Use)

Description Eric Floehr 2013-12-03 02:20:51 UTC
Description of problem:

This is the same problem experienced in Bug #1035448 (https://bugzilla.redhat.com/show_bug.cgi?id=1035448) but for Fedora 19, not 20.

The issue is that Fedora 19 runs fine if running and connected to the dock as long as there are no external monitors hooked up. It also boots fine in the dock if no external monitors are connected.

However, if you attach to the dock or boot in the dock with an external monitor attached (I've tried VGA, DVI-D, and DisplayPort connections and all exhibit the issue) the system freezes... nothing gets output to the displays, no keyboard presses are registered, and nothing is output to /var/log/messages or /var/log/Xorg.0.log save for the initial connect event (example shown is attaching DVI-D to system running in dock):

/var/log/messages:
Dec  2 21:06:41 tawodi colord: Device added: xrandr-Dell Inc.-DELL 2408WFP-JU4368251EGS
... nothing until disconnect, this case I had to disconnect from dock, unplugging DVI-D did nothing...
Dec  2 21:07:20 tawodi colord: device removed: xrandr-Dell Inc.-DELL 2408WFP-JU4368251EGS
Dec  2 21:07:20 tawodi kernel: [  685.991740] thinkpad_acpi: undocked from hotplug port replicator


/var/log/Xorg.0.log:
[   646.188] (II) intel(0): EDID vendor "AUO", prod id 4669
[   646.188] (II) intel(0): Printing DDC gathered Modelines:
[   646.188] (II) intel(0): Modeline "1920x1080"x0.0  141.00  1920 1936 1952 2104  1080 1083 1097 1116 -hsync -vsync (67.0 kHz eP)
[   646.257] (II) intel(0): EDID vendor "AUO", prod id 4669
[   646.257] (II) intel(0): Printing DDC gathered Modelines:
[   646.257] (II) intel(0): Modeline "1920x1080"x0.0  141.00  1920 1936 1952 2104  1080 1083 1097 1116 -hsync -vsync (67.0 kHz eP)
[   646.355] (II) intel(0): Allocated new frame buffer 3840x1200 stride 15360, tiled
... and that's the last, until undock...

On boot, the system shows the grub menu, and flashes before going blank and freezing. Undocking shows the fedora progress icon in a partial state. Sometimes it will come out of freeze, sometimes you have to undock in order for it to unfreeze. No error messages show in any /var/log file.

So it could be something in the thinkpad drivers, but could also be something in the Intel video drivers. Hardware:

Intel Core i7-4600U 2.10GHz (haswell)
Intel Haswell-ULT Integrated Graphics
ThinkPad t440s
ThinkPad Ultra Dock (40A20090US)
Dell 2408WFP monitor at 1920x1200 resolution


Version-Release number of selected component (if applicable):

Kernel: 3.11.9-200.fc19.x86_64
Video: xorg-x11-drv-intel-2.21.12-2.fc19.x86_64


How reproducible:
Always.


Steps to Reproduce:
1a. Connect ThinkPad to dock. Connect external monitors to dock. Boot.

or:

1b. Connect ThinkPad to dock without external monitors attached. Boot. After boot, connect external monitor(s) to dock.


Actual results:

System freezes, nothing displayed on monitors, no interaction possible.


Expected results:

System boots or continues to run properly.


Additional info:

Please let me know what I can do to gather info and test. I am more than willing to help!

Comment 1 Eric Floehr 2013-12-03 19:14:55 UTC
As a test, I tried other distros to see if this was a distro-specific issue.

Linux Mint 16 wouldn't get past the boot screen even removed from dock.

OpenSUSE 13.1 installs, but exhibits the same behavior as Fedora 19 and 20.

Comment 2 Eric Floehr 2013-12-04 12:40:28 UTC
This bug on freedesktop.org might be the root: https://bugs.freedesktop.org/show_bug.cgi?id=71267

Comment 3 Ferry Huberts 2013-12-04 13:19:07 UTC
I have this issue too.
I saw that it's been reported by more people after doing a google search.

Connecting a DisplayPort display to the T440s directly (on its mini-dp connector) does work. So it's the connectors on the dock that do not work.

Comment 4 Ferry Huberts 2013-12-04 13:29:38 UTC
(In reply to Eric Floehr from comment #2)
> This bug on freedesktop.org might be the root:
> https://bugs.freedesktop.org/show_bug.cgi?id=71267

agree

Comment 5 Havoc Pennington 2013-12-04 15:49:36 UTC
*** Bug 1035448 has been marked as a duplicate of this bug. ***

Comment 6 Havoc Pennington 2013-12-04 15:51:09 UTC
Confirmed in Fedora 20 beta also (see https://bugzilla.redhat.com/show_bug.cgi?id=1035448)

Comment 7 Kristian Karl 2014-01-08 09:02:39 UTC
I experience the same with X240 and 3.12.6-300.fc20.x86_64

Comment 8 Andrew Dunn 2014-01-14 13:37:52 UTC
I experience the same issue with T540p (intel gfx) and 3.12.6-300.fc20.x86_64

Comment 9 Håkan Hagenrud 2014-01-31 12:55:26 UTC
We have the same problem, connecting the external monitor to the DisplayPort on the computer works.

Comment 10 John Eckersberg 2014-02-07 15:43:22 UTC
I've been able to get this backtrace at the freeze point:

#0  0x00000030842ec067 in ioctl () at ../sysdeps/unix/syscall-template.S:81
#1  0x000000308c2036e4 in drmIoctl (fd=10, request=request@entry=3228066978, arg=0x7fffea8caa10) at xf86drm.c:167
#2  0x000000308c2077b9 in DRM_IOCTL (arg=0x7fffea8caa10, cmd=3228066978, fd=<optimized out>) at xf86drmMode.c:57
#3  drmModeSetCrtc (fd=<optimized out>, crtcId=<optimized out>, bufferId=<optimized out>, x=<optimized out>, y=<optimized out>, connectors=<optimized out>, count=1, mode=0xaf1b98) at xf86drmMode.c:383
#4  0x00007ff0147b8d44 in intel_crtc_apply () from /usr/lib64/xorg/modules/drivers/intel_drv.so
#5  0x00007ff0147b92e0 in intel_crtc_set_mode_major () from /usr/lib64/xorg/modules/drivers/intel_drv.so
#6  0x00000000004c3d2d in xf86CrtcSetModeTransform (crtc=crtc@entry=0xaf1c40, mode=mode@entry=0x7fffea8cae60, rotation=rotation@entry=1, transform=transform@entry=0x0, x=x@entry=1920, y=y@entry=0)
    at xf86Crtc.c:297
#7  0x00000000004cd5f6 in xf86RandR12CrtcSet (pScreen=0xaf8020, randr_crtc=0xe10310, randr_mode=<optimized out>, x=1920, y=0, rotation=<optimized out>, num_randr_outputs=1, randr_outputs=0x126e7b0)
    at xf86RandR12.c:1216
#8  0x000000000050c6ae in RRCrtcSet (crtc=0xe10310, mode=0x1239830, x=1920, y=0, rotation=rotation@entry=1, numOutputs=numOutputs@entry=1, outputs=outputs@entry=0x126e7b0) at rrcrtc.c:567
#9  0x000000000050dbd6 in ProcRRSetCrtcConfig (client=0x1153d70) at rrcrtc.c:1167
#10 0x000000000043a357 in Dispatch () at dispatch.c:432
#11 0x00000000004288ea in main (argc=12, argv=0x7fffea8cb388, envp=<optimized out>) at main.c:298


Here's a link to the full core file:
http://people.redhat.com/~jeckersb/core.2847

This is with:
kernel-3.12.9-301.fc20.x86_64
xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64

Comment 11 Tom "spot" Callaway 2014-02-10 19:23:23 UTC
I have this issue as well, looks like Lenovo has pinned this down to a bug in the _dock_ firmware:

https://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T540p-T440p-UltraDock-external-display-issues/m-p/1428373#M92038

Comment 12 Eric Floehr 2014-02-14 16:35:48 UTC
It appears that the issue was firmware, not buggy Linux, see the freedesktop upstream bug. I am closing this issue.

Comment 13 Ferry Huberts 2014-02-14 17:32:00 UTC
It's _both_ a firmware problem of the dock and of the Linux kernel.

The Intel guys are supposedly queueing patches for the current development and stable kernels

Comment 14 Eric Floehr 2014-02-14 17:33:46 UTC
Right, I guess it shouldn't hang on unpatched firmware, and that's the bugfix.

Comment 15 James (purpleidea) 2014-05-26 23:22:47 UTC
FWIW: https://bugzilla.redhat.com/show_bug.cgi?id=1086978


Note You need to log in before you can comment on or make changes to this bug.