This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103546 - new gnome-session doesn't run ~/.Xclients
new gnome-session doesn't run ~/.Xclients
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gdm (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-02 00:00 EDT by Alexandre Oliva
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.4.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 18:07:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix default session thingie (952 bytes, patch)
2003-09-02 20:47 EDT, George Lebl
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2003-09-02 00:00:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After upgrading my laptop, that was running the original Severn, with all
updates available in the severn updates RHN channel, logging in in gnome (with
gdm) no longer runs ~/.Xclients.  I noticed that, before the update, ps -fax
contained lines lke this:

13815 ?        S      0:00 /usr/bin/gdm-binary -nodaemon
13871 ?        S      0:00  \_ /usr/bin/gdm-binary -nodaemon
21318 ?        R      2:16      \_ /usr/X11R6/bin/X :0 -auth /var/gdm/:0.Xauth vt7
21434 ?        S      0:00      \_ /usr/bin/gnome-session
21523 ?        S      0:00          \_ /usr/bin/ssh-agent /home/aoliva/.Xclients

but after the update, the argument to ssh-agent is now gnome-session, i.e., the
execution of .Xclients seems to be short-circuited.  Was this change
intentional?  If so, what's the recommended way to do this now?

Version-Release number of selected component (if applicable):
gnome-session-2.3.7-3

How reproducible:
Always

Steps to Reproduce:
1.Create an executable shell script in ~/.Xclients that runs say ssh-add
.ssh/identity, then /etc/X11/xinit/Xclients
2.Log in and notice that it asks for the password that protects the ssh identity
3.Install all updates available in the Severn updates channel
4.Log in again

Actual Results:  It no longer asks for the password for the SSH identity

Expected Results:  It should

Additional info:
Comment 1 Havoc Pennington 2003-09-02 10:49:27 EDT
The way I thought it worked was:
 - if you choose the GNOME session in gdm, gnome-session gets run
 - if you choose the "Default" session .Xclients gets run if present, falling 
   back to gnome-session

I have no idea though how you got gnome-session to run .Xclients
Comment 2 Bill Nottingham 2003-09-02 13:48:53 EDT
I'm noticing similar behavior on current updates; before, my .Xclients was run,
now it's not. Note that this is the file switchdesk wrote.

(In my case, the ssh-add's that I have as part of my session get run, but
they're now talking to the wrong ssh-agent.)
Comment 3 Bill Nottingham 2003-09-02 14:00:49 EDT
This is due to the xinitrc change for Xsession; it now runs whatever the first
argument passed to it is, as long as it's not 'default' or 'custom'. Perhaps
it's because the check is case-sensitive, or we're not migrating the users
default/custom setting right?
Comment 4 Alexandre Oliva 2003-09-02 18:26:20 EDT
Looks like it's a default migration issue, indeed.  If I select `Default system
session' (sp?) instead of `Same as last login' (sp?), then my .Xclients is run
again, and if I make it the default, then it works permanently.
Comment 5 George Lebl 2003-09-02 20:46:43 EDT
I see what's going on.  We are not setting the default right.  The default has
now been set to gnome.desktop which is the default for the upstream tarball, but
in RH we want the default to be Default.desktop.  So I'm attaching a patch to
add to the rpm to fix this.  We were also missing the
greeter/ShowLastSession=false which is the "switchdesk mode" of gdm.  So will
attach a patch to fix this.
Comment 6 George Lebl 2003-09-02 20:47:19 EDT
Created attachment 94161 [details]
patch to fix default session thingie
Comment 7 Alexander Larsson 2003-09-04 09:07:58 EDT
I added this patch to gdm 2.4.4.0-2, can you try it?
Comment 8 Alexandre Oliva 2003-09-04 18:01:47 EDT
Thanks, it *seems* to have fixed it, but I couldn't really guarantee it fixed
the original problem because I'd already changed my default session to whatever
the version in RHN Severn updates used as the default session.  It did open a
popup window when I first logged in after the upgrade, though, letting me know
it was using the default session as the default session (or something slightly
amusing to that effect :-)  I suppose this wouldn't have happened had I upgraded
directly from the original Severn gdm to this one.
Comment 9 Alexandre Oliva 2003-09-04 18:07:31 EDT
It occurred to me that, if I downgraded to the original severn, logged in once
choosing the default session at that time, I'd go back to the original settings.
 Then, upgrading to the new package again and logging in would presumably show
whether the problem was fixed.  If this is true, then the problem is indeed
fixed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.