Bug 1035503 - [abrt] iotop-0.6-1.fc19: wrapper.py:49:wrapper:error: nocbreak() returned ERR
Summary: [abrt] iotop-0.6-1.fc19: wrapper.py:49:wrapper:error: nocbreak() returned ERR
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: iotop
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:97dbff5367e4fce2ee8ad0afcc0...
: 885593 1079902 1123181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-27 23:56 UTC by Kamil Páral
Modified: 2015-03-05 12:40 UTC (History)
8 users (show)

Fixed In Version: iotop-0.6-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-03 12:04:48 UTC


Attachments (Terms of Use)
File: backtrace (1011 bytes, text/plain)
2013-11-27 23:57 UTC, Kamil Páral
no flags Details
File: environ (482 bytes, text/plain)
2013-11-27 23:57 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2013-11-27 23:56:56 UTC
Description of problem:
I closed my terminal while iotop was running (therefore I assume iotop should have received sigterm or something).

Version-Release number of selected component:
iotop-0.6-1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /sbin/iotop -o -d 2
dso_list:       python-libs-2.7.5-9.fc19.x86_64
executable:     /sbin/iotop
kernel:         3.11.9-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
wrapper.py:49:wrapper:error: nocbreak() returned ERR

Traceback (most recent call last):
  File "/sbin/iotop", line 17, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 620, in main
    main_loop()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 610, in <lambda>
    main_loop = lambda: run_iotop(options)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 508, in run_iotop
    return curses.wrapper(run_iotop_window, options)
  File "/usr/lib64/python2.7/curses/wrapper.py", line 49, in wrapper
    curses.nocbreak()
error: nocbreak() returned ERR

Local variables in innermost frame:
stdscr: <_curses.curses window object at 0x7ff05087a168>
func: <function run_iotop_window at 0x7ff0488801b8>
kwds: {}
args: (<Values at 0x7ff0488811b8: {'profile': False, 'delay_seconds': 2.0, 'users': None, 'processes': False, 'batch': 0, 'only': True, 'quiet': 0, 'iterations': None, 'time': None, 'accumulated': False, 'pids': [], 'kilobytes': False, 'uids': []}>,)

Potential duplicate: bug 1022591

Comment 1 Kamil Páral 2013-11-27 23:57:04 UTC
Created attachment 829947 [details]
File: backtrace

Comment 2 Kamil Páral 2013-11-27 23:57:07 UTC
Created attachment 829948 [details]
File: environ

Comment 3 kartochka22 2014-08-07 07:52:56 UTC
got it when press close button on gnome-terminal, with iotop running inside su - root shell. F20 with all updates.

Comment 4 Michal Hlavinka 2014-12-03 16:06:48 UTC
*** Bug 1079902 has been marked as a duplicate of this bug. ***

Comment 5 Michal Hlavinka 2014-12-03 16:06:52 UTC
*** Bug 1123181 has been marked as a duplicate of this bug. ***

Comment 6 Michal Hlavinka 2014-12-03 16:54:31 UTC
*** Bug 885593 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-12-04 10:22:03 UTC
iotop-0.6-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iotop-0.6-2.fc19

Comment 8 Fedora Update System 2014-12-04 10:22:10 UTC
iotop-0.6-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/iotop-0.6-3.fc20

Comment 9 Fedora Update System 2014-12-04 10:22:19 UTC
iotop-0.6-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/iotop-0.6-4.fc21

Comment 10 Fedora Update System 2014-12-18 06:11:32 UTC
iotop-0.6-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-01-07 01:26:59 UTC
iotop-0.6-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 kartochka22 2015-01-24 01:23:57 UTC
Another user experienced a similar problem:

iotop run in gnome-terminal in "su-" nested session. abrt window pop when i trying to close GNOME w/o manually close applications as terminal, just use "off" button at right top gnome GUI.

 Note:bash downgraded to bash-4.3.30-2.fc21 as i get tired of autocomplete issue with spaces or non english letters in file names.

reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /sbin/iotop
dso_list:       python-libs-2.7.8-7.fc21.x86_64
executable:     /sbin/iotop
kernel:         3.17.8-300.fc21.x86_64
package:        iotop-0.6-4.fc21
reason:         wrapper.py:49:wrapper:error: nocbreak() returned ERR
runlevel:       N 5
type:           Python
uid:            0

Comment 13 Stan King 2015-01-29 22:51:54 UTC
Another user experienced a similar problem:

I think this happened when I dismissed the Terminal window in which I was running iotop, instead of halting iotop with control-C.

reporter:       libreport-2.3.0
cmdline:        /usr/bin/python /sbin/iotop
dso_list:       python-libs-2.7.8-7.fc21.x86_64
executable:     /sbin/iotop
kernel:         3.18.3-201.fc21.x86_64
package:        iotop-0.6-4.fc21
reason:         wrapper.py:49:wrapper:error: nocbreak() returned ERR
runlevel:       N 5
type:           Python
uid:            0

Comment 14 Fedora Update System 2015-01-30 18:46:34 UTC
iotop-0.6-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/iotop-0.6-5.fc21

Comment 15 Fedora Update System 2015-01-30 18:46:44 UTC
iotop-0.6-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/iotop-0.6-4.fc20

Comment 16 Fedora Update System 2015-02-01 00:26:19 UTC
Package iotop-0.6-5.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iotop-0.6-5.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1502/iotop-0.6-5.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-02-03 12:04:48 UTC
iotop-0.6-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Stan King 2015-02-05 01:49:45 UTC
Version 0.6-5 seems better so far.  Thanks.

Comment 19 Fedora Update System 2015-03-05 12:40:33 UTC
iotop-0.6-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.