Bug 1123181 - [abrt] iotop: wrapper.py:49:wrapper:error: nocbreak() returned ERR
Summary: [abrt] iotop: wrapper.py:49:wrapper:error: nocbreak() returned ERR
Keywords:
Status: CLOSED DUPLICATE of bug 1035503
Alias: None
Product: Fedora
Classification: Fedora
Component: iotop
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:97dbff5367e4fce2ee8ad0afcc0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 04:44 UTC by Chris Murphy
Modified: 2014-12-03 16:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-03 16:06:52 UTC


Attachments (Terms of Use)
File: backtrace (1015 bytes, text/plain)
2014-07-25 04:44 UTC, Chris Murphy
no flags Details
File: environ (2.52 KB, text/plain)
2014-07-25 04:44 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2014-07-25 04:44:50 UTC
Version-Release number of selected component:
iotop-0.6-3.fc21

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/sbin/iotop -o -d5
dso_list:       python-libs-2.7.7-2.fc21.x86_64
executable:     /usr/sbin/iotop
kernel:         3.16.0-0.rc6.git0.1.fc21.1.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
wrapper.py:49:wrapper:error: nocbreak() returned ERR

Traceback (most recent call last):
  File "/usr/sbin/iotop", line 17, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 620, in main
    main_loop()
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 610, in <lambda>
    main_loop = lambda: run_iotop(options)
  File "/usr/lib/python2.7/site-packages/iotop/ui.py", line 508, in run_iotop
    return curses.wrapper(run_iotop_window, options)
  File "/usr/lib64/python2.7/curses/wrapper.py", line 49, in wrapper
    curses.nocbreak()
error: nocbreak() returned ERR

Local variables in innermost frame:
stdscr: <_curses.curses window object at 0x7f18ef95f138>
func: <function run_iotop_window at 0x7f18e6372488>
kwds: {}
args: (<Values at 0x7f18e6374518: {'profile': False, 'delay_seconds': 5.0, 'users': None, 'processes': False, 'batch': 0, 'only': True, 'quiet': 0, 'iterations': None, 'time': None, 'accumulated': False, 'pids': [], 'kilobytes': False, 'uids': []}>,)

Potential duplicate: bug 1022591

Comment 1 Chris Murphy 2014-07-25 04:44:51 UTC
Created attachment 920793 [details]
File: backtrace

Comment 2 Chris Murphy 2014-07-25 04:44:52 UTC
Created attachment 920794 [details]
File: environ

Comment 3 Michal Hlavinka 2014-12-03 16:06:52 UTC

*** This bug has been marked as a duplicate of bug 1035503 ***


Note You need to log in before you can comment on or make changes to this bug.