Bug 103630 - Missed buildreq: perl >= 5.8.1
Summary: Missed buildreq: perl >= 5.8.1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: foomatic   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-09-03 11:28 UTC by Leonid Kanter
Modified: 2007-04-18 16:57 UTC (History)
2 users (show)

Fixed In Version: 3.0.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 09:42:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2003-09-03 11:28:54 UTC
Description of problem:

foomatic rpm cannot be rebuilt from non-root user because it tries to write to
root filesystem

Version-Release number of selected component (if applicable):

3.0.0-7

How reproducible:

always

Steps to Reproduce:
1. set up non-root rpm building environment
2. rpmbuild --rebuild foomatic-3.0.0-7.src.rpm
    
Actual results:

make[1]: Entering directory
`/home/leon/RPM/BUILD/foomatic-3.0.0/foomatic-db-engine-3.0.0/lib'
Warning: You do not have permissions to install into
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi at
/usr/lib/perl5/5.8.0/ExtUtils/Install.pm line 84.
Cannot forceunlink /usr/lib/perl5/vendor_perl/5.8.0/Foomatic/DB.pm: Permission
denied at /usr/lib/perl5/5.8.0/File/Find.pm line 849

Expected results:

Successful building of package

Comment 1 Tim Waugh 2003-09-03 16:50:53 UTC
Works for me.  Please provide the complete build log.

Comment 2 Leonid Kanter 2003-09-04 09:11:01 UTC
My build environment was based on partially upgraded RH9, and this problem was
fixed for me by updating perl from 5.8.0-88 to 5.8.1-90.rc4.2. So the reason of
bug report is missed build requirement.


Comment 3 Thomas Dodd 2003-12-16 21:05:13 UTC
I'me confused as to what requires the newer Perl here.

The description sounds like a problem with the Install.pm no
installing to $RPM_BUILD_ROOT like it should. Why would using a newer
perl be the fix? Souns like $RPM_BUILD_ROOT is not getting passed/used
correctly in foomatic-db-engine.

FWIW, Removing the BuildRequires and Requires line goes farther
(building as root). But it stops in the files section with:

File not found by glob:
/var/tmp/foomatic-3.0.0-13-root/usr/lib*/perl5/vendor_perl/*/Foomatic

Looks like the make files are setting INSTALLSITELIB to
/usr/lib/perl5/vendor_perl/5.8.0 (similar for INSTALLSITEARCH).

For example, a .packlist file is created in
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Foomatic
instead of under $RPM_BUILD_ROOT.

Comment 4 Tim Waugh 2003-12-17 15:01:24 UTC
Works for me.

Comment 5 Thomas Dodd 2003-12-17 15:57:50 UTC
What works? Building with 5.8.0 or something newer?

Not sure what affect changing perl would have, so I'm hesitant to do so.

Have you got a current RHL-9 system to build on?
Could you try it?

If perl5.8.1 is really needed, the foomatic guys should know. If it's
not needed, the dependencies should be changed.

I'd like to check the new printing (foomatic, Omni, cups) system, but
cannot move to FC1 just yet.  I need to change my disk layout, but
haven't been able to backup everything. Trying to get a tape going.


Comment 6 Tim Waugh 2003-12-17 16:03:38 UTC
With 5.8.1.


Note You need to log in before you can comment on or make changes to this bug.