This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103679 - ls -la Input/output errors
ls -la Input/output errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 103680 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 16:16 EDT by Ken Leung
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 06:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ken Leung 2003-09-03 16:16:15 EDT
Description of problem: "ls -la" on NFS filesystem first produces Input/output 
errors then followed by the correct results


Version-Release number of selected component (if applicable):


How reproducible: probably easy to reproduce


Steps to Reproduce:
1. Mount NFS filesystem 
2. Cd to the mounted filesystem
3. Perform an "ls -la" in some directories
    
Actual results: ls -la returns "ls: file/dir Input/output error" for each 
file/dir, followed by the correct expected results of an ls command. Sample 
output:

[root@perseus1 kleung]# ls -la
ls: .: Input/output error
ls: ..: Input/output error
ls: .gtkrc: Input/output error
ls: Oracle: Input/output error
(and so on)
total 640
drwxr-xr-x   39 kleung   users        2048 Sep  3 12:31 .
drwxr-xr-x   45 root     root         1536 Aug 14 15:32 ..
-rw-r--r--    1 kleung   users         120 Sep  3 12:29 .gtkrc
drwxr-xr-x    4 kleung   users        1536 Aug 28 10:22 Oracle
(and so on)
[root@perseus1 kleung]# 

Expected results: ls -la should provide a listing of all the files/dirs in a 
directory


Additional info: ls -la can obviously see and list the files in the directory 
since the correct results are returned following those "Input/output error" 
messages. RedHat ES 2.1 prints results of an "ls -la" on the same directory 
without the errors, and so do RedHat 7.2, 7.3, 8.0, and 9.
Comment 1 Ken Leung 2003-09-03 16:27:24 EDT
*** Bug 103680 has been marked as a duplicate of this bug. ***
Comment 2 Ken Leung 2003-09-03 16:35:43 EDT
A simple "ls" or "ls -a" does not generate the Input/output errors, only when 
you use the "-l" option.
Comment 3 Ken Leung 2003-09-04 12:32:28 EDT
Which current release fixes it? I am running the newest beta version of ES3. We 
want to migrate all of our servers to enterprise, but need GCC 3.2 which is why 
ES 2.1 isn't right for us.

Note You need to log in before you can comment on or make changes to this bug.