Bug 103762 - mutt segfaults when starting view-attachments menu from index
mutt segfaults when starting view-attachments menu from index
Status: CLOSED DUPLICATE of bug 97216
Product: Red Hat Linux
Classification: Retired
Component: mutt (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 14:08 EDT by Everett Lipman
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the offending message (1.43 KB, text/plain)
2003-09-04 14:09 EDT, Everett Lipman
no flags Details

  None (edit)
Description Everett Lipman 2003-09-04 14:08:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
mutt segfaults when I try to start the view-attachments menu
from the initial index.

Version-Release number of selected component (if applicable):
mutt-1.4.1-1

How reproducible:
Always

Steps to Reproduce:
1.mutt -f sfmsg (this file is attached)
2.Type 'v'
3.
    

Actual Results:  Program received signal SIGSEGV, Segmentation fault.
0x08074c34 in strcpy ()
(gdb) 


Expected Results:  should have seen attachments menu

Additional info:

This still happens when I remove my .muttrc and just
use the system default.
Comment 1 Everett Lipman 2003-09-04 14:09:48 EDT
Created attachment 94210 [details]
the offending message
Comment 2 Everett Lipman 2003-09-04 14:14:32 EDT
The Content-Length fields are not correct in the
attached message because I edited the message
to remove identifying information.  Both
the original and the attached messages cause
the problem.
Comment 3 Bill Nottingham 2003-09-04 14:24:28 EDT
What happens if you rebuild mutt against current rawhide slang?
(Alternatively, does rawhide mutt segfault?)
Comment 4 Everett Lipman 2003-09-04 18:23:10 EDT
I don't know what "rawhide slang" is.  I can't really afford
the time to start debugging this myself.
Comment 5 Bill Nottingham 2003-09-04 18:47:18 EDT
I've tried on both current mutt packages, and a Red Hat Linux 9 install. It
works for me in both cases.

If you install http://people.redhat.com/notting/mutt-debuginfo-1.4.1-1.i386.rpm,
and *then* get it to segfault, what is the backtrace? (It should be a more
useful backtrace then...)
Comment 6 Everett Lipman 2003-09-04 19:51:48 EDT
Program received signal SIGSEGV, Segmentation fault.
0x08074c34 in print_enriched_string (attr=0, 
    s=0xbfffce3a "\003\004\a<no description>", ' ' <repeats 16 times>,
"[text/plain, 7bit, us-ascii, 0.1K] ", do_color=1) at menu.c:57
57                    addch (ACS_LLCORNER);
(gdb) bt
#0  0x08074c34 in print_enriched_string (attr=0, 
    s=0xbfffce3a "\003\004\a<no description>", ' ' <repeats 16 times>,
"[text/plain, 7bit, us-ascii, 0.1K] ", do_color=1) at menu.c:57
#1  0x08075208 in menu_redraw_index (menu=0x80ddc90) at menu.c:257
#2  0x08076ad8 in mutt_menuLoop (menu=0x80ddc90) at menu.c:846
#3  0x0808a246 in mutt_view_attachments (hdr=0x80df9f8) at recvattach.c:902
#4  0x0805fa19 in mutt_index_menu () at curs_main.c:1958
#5  0x08072655 in main (argc=3, argv=0xbfffdeb4) at main.c:842
#6  0x420156a4 in __libc_start_main () from /lib/tls/libc.so.6
(gdb) 
Comment 7 Bill Nottingham 2003-09-04 21:45:01 EDT
This was fixed in slang. Current mutt packages in rawhide should be fine.

*** This bug has been marked as a duplicate of 97216 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:58:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.