Bug 97216 - mutt's "v" command execution crashes in slang library
mutt's "v" command execution crashes in slang library
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: slang (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
:
: 97213 103762 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 12:39 EDT by matti aarnio
Modified: 2007-04-18 12:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4.5-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-13 16:54:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matti aarnio 2003-06-11 12:39:26 EDT
Description of problem:
Read into mutt a folder with messages containing
a  multipart/mixed{ multipart/alternative{ text/plain, text/html },
                    application/anything }
Attempting to "view" the message structure with "v" command results
SEGV in  addch()  call, which lengthy debugging session did show up
to be  slang-library  function  SLcurses_waddch()  via couple macro
redirects.

This appeared after I had updated kernel, glibc, lots of other
libraries, and had restarted the system.  I hadn't updated either
mutt, nor slang at that point.  After updating both, the problem
didn't disappear.

Recompining the mutt with slang removed from its SPEC file, the mutt
with standard ncurses (-5 ?) does work just fine.

Version-Release number of selected component (if applicable):
slang-1.4.5-17

How reproducible:
Always

Steps to Reproduce:
1. have suitably complex structured message in a test folder
   (e.g. text+html type accompanying letter + any attachment)
2. current rawhide system
3. mutt -f test.msg
4. try to view ("v") message's structure
    

Actual Results:  SEGV

Expected Results:  view of the message structure..

Additional info:

Is this related somehow to glibc locale handling ? (maybe)
Or to slang-library bitrot ?  (hardly)
Or to a new  2.4.20-20.1.2007.nptl  kernel ?  (hardly)

Ah, indeed..

  LC_CTYPE=C        -> no problem
  LC_CTYPE=fi_FI    -> SEGV

I need "non-C" locale, so this isn't an easy work-around..

Anyway, slang-source version is a bit oldish, and could
be updated.
Comment 1 matti aarnio 2003-06-11 12:53:04 EDT
*** Bug 97213 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-06-13 16:54:53 EDT
Fixed in slang-1.4.5-18, you'll need to rebuild mutt against it (mutt should be
fixed in 1.4.1-3.)
Comment 3 Bill Nottingham 2003-09-04 21:45:03 EDT
*** Bug 103762 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.