Bug 10381 - Software RAID upgrade RH61 -> RH62 not working
Software RAID upgrade RH61 -> RH62 not working
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-28 05:38 EST by Jussi Torhonen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-30 09:39:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Torhonen 2000-03-28 05:38:19 EST
Tried to upgrade RH 6.1 with software RAID up to RH 6.2 'Zoot' final. Both
text and graphical mode installer hangs when 'Finding packages to
upgrade...'. Text mode installer crashes and graphical one just hangs. Text
mode installer shows a debug window and when selected Debug, it showed the
following lines:

> /usr/lib/anaconda/fstab.py(705)readFstab()
-> fields[2], raidByDev[int(fields[0][7:])])

Reported the same bug here in Bugzilla for RH 6.1.92 beta and then
the case was closed as 'resolved'. Well, it4s not. Tried to query the
bug-id, but didn't success. The whole report has disapperared.

BTW, any chance to grab debug info text into a file on a floppy disk when
installer crashes ? Too much text to write down in that debug window.

Regards,
Jussi, jt@iki.fi
Comment 1 Brock Organ 2000-03-28 15:41:59 EST
I am unable to reproduce the problem ... I tried two i386 6.1 -> 6.2 upgrades
(both 6.1 GNOME workstation installs), one with / on a native ext2 (and other
raided partitions) and one with / on a raided ext2, both upgrades succeeded in
GUI mode ...
Comment 2 Jussi Torhonen 2000-03-29 00:03:59 EST
Found my previous bug report for RH 6.1.92 about this same problem.
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=9331
There you find disks and partitins on this problematic host.
Then the reason for problem was bigger RAID5 volume than the installer
understood. Perhaps it's still the same or perhaps not. Anyway
this host is up and running RH 6.1 without any problems. There's no mess in
/etc/fstab. Cannot say why installer can't initialize fstab.

Regards,
Jussi, jt@iki.fi
Comment 3 Brock Organ 2000-03-29 15:09:59 EST
duplicated in the test lab using a random scsi card & drives on test166 ...

*** This bug has been marked as a duplicate of 9331 ***
Comment 4 Erik Troan 2000-03-29 18:23:59 EST
This was not a duplicate.

A fix is available at ftp://people.redhat.com/ewt/raid-fix. You need to
do the following:

	1) Download the proper boot disk for your setup
	2) Download raid-fix.img (an anaconda updates disk)
	3) Write both disks to floppies
	4) Boot the boot disk with "linux updates" at the boot prompt
	5) Use the raid-fix.img disk as the updates disk (you will be prompted
	   for this before anaconda is run)

This should fix the problem. Please let us know what happens either way.
Comment 5 Jussi Torhonen 2000-03-30 03:40:59 EST
Thanks ! Now the system was upgraded without a single problem. Used text mode
installer 'linux text updates'.

Regards,
Jussi, jt@iki.fi
Comment 6 Erik Troan 2000-03-30 09:39:59 EST
Problem solved by given instructions.
Comment 7 André Johansen 2000-05-09 13:44:59 EDT
I've had the same problem as reported in this bug-report, and I've tested the default image
coming with 6.2, the 20000407 upgrade, the RawHide version and the one mentioned above.
All give the same error when scanning the disks for installed system. I'm upgrading
a v6.1 to v6.2, the system is a dual P3 with software raid 0+1.

The errors reported (text upgrade) is something like `invalid mount option'. This happens for
all the e2fs partitions in the array. A debug trace is then shown and the installer exits when
pressing ok.

Also, after the upgrade attempt, the disks has to be fsck'ed when booting the old 6.1 system.

Is there any other way to do the upgrade? I seriously need to upgrade the system, as 6.1
has some nasty deadlock and signal bugs when running threaded programs (which are
removed in 6.2).
Comment 8 Erik Troan 2000-05-09 14:13:59 EDT
Can you give us details on the traceback you are getting?

Note You need to log in before you can comment on or make changes to this bug.