Bug 9331 - Software RAID upgrade RH 6.1 -> RH 6.1.92 doesn't work
Software RAID upgrade RH 6.1 -> RH 6.1.92 doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-11 02:07 EST by Jussi Torhonen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-29 18:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jussi Torhonen 2000-02-11 02:07:03 EST
Tried to upgrade an existing RH 6.1 installation up to RH 6.1.92 without a
success. Host has Adaptec 78xx controller with 4 SCSI disks, one DAT drive
and one SCSI CD-ROM drive. /dev/sda is the boot disk and the rest of the
disks sdb/sdc/sdd are configured as a software RAID 5 volume. Installation
was originally done with GUI installation of RH 6.1.
boot.img disk boots fine, selected 'Upgrade...', installer loaded aha78xx
modules and started searching installed packages and then crashed with an
anaconda/pyhton error window. It looks like software RAID upgrade doesn't
work.

Regards,
Jussi, jt@iki.fi
Comment 1 Jay Turner 2000-02-11 16:21:59 EST
How many RAID partitions did you have?  I am betting that you had more than one
and that is the problem.  If that is the case, it is a known problem and we are
working on it.
Comment 2 Jussi Torhonen 2000-02-14 00:48:59 EST
Partitions are:

# df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda1              1929068    727160   1103916  40% /
/dev/md0               5818752   1110436   4412740  20% /home

# fdisk /dev/sda

Command (m for help): p

Disk /dev/sda: 255 heads, 63 sectors, 261 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1       244   1959898+  83  Linux
/dev/sda2           245       261    136552+   5  Extended
/dev/sda5           245       261    136521   82  Linux swap

Software RAID configured as:

# cat /etc/raidtab
raiddev             /dev/md0
raid-level                  0
nr-raid-disks               3
chunk-size                  64k
persistent-superblock       1
#nr-spare-disks     0
    device          /dev/sdb5
    raid-disk     0
    device          /dev/sdd5
    raid-disk     1
    device          /dev/sdc5
    raid-disk     2

SCSI devices connected are:

# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: CONNER   Model: CFP2105S  2.14GB Rev: 2D4D
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: SEAGATE  Model: ST32430N         Rev: 0510
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: IBM      Model: DCAS-32160       Rev: S65A
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 03 Lun: 00
  Vendor: IBM      Model: DCAS-32160       Rev: S65A
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: HP       Model: C1533A           Rev: 9406
  Type:   Sequential-Access                ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: MATSHITA Model: CD-ROM CR-504    Rev: ST23
  Type:   CD-ROM                           ANSI SCSI revision: 02

Regards,
Jussi, jt@iki.fi
Comment 3 Jay Turner 2000-02-15 20:01:59 EST
This was the result of a signed/unsigned error in the code and is now fixed and
will appear in the next cut of the beta that we make available.  Basically the
RAID partition was too big and was causing strange things to happen (overflow of
a signed number that is!)
Comment 4 Brock Organ 2000-03-29 15:09:59 EST
*** Bug 10381 has been marked as a duplicate of this bug. ***
Comment 5 Brock Organ 2000-03-29 15:17:59 EST
this behavior has been duplicated using a random scsi card & drives (test166)
Comment 6 Erik Troan 2000-03-29 18:21:59 EST
Bug 10381 is not actually a duplicate of this bug. This bug is fixed.

Note You need to log in before you can comment on or make changes to this bug.