Bug 103829 - devel package has incorrect dependencies
devel package has incorrect dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: librsvg2 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 103838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 09:51 EDT by Chris Ricker
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 10:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-05 09:51:21 EDT
I get the following when using yum to update to today's rawhide:


Resolving dependencies
....identical dependency loop exceeded
package librsvg2-devel needs librsvg2 = %{epoch}:2.3.1-2 (not provided)

The problem appears to be use of a macro in the spec file for epoch w/o ever
defining it:

[root@server1 RPMS]# rpm -qpR librsvg2-devel-2.3.1-2.i386.rpm 
warning: librsvg2-devel-2.3.1-2.i386.rpm: V3 DSA signature: NOKEY, key ID e418e3aa
freetype-devel >= 2.0.1
gtk2-devel >= 2.2.0
libart_lgpl-devel >= 2.3.10
libgsf-devel  
librsvg2 = %{epoch}:2.3.1-2
libxml2-devel >= 2.4.12
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@server1 RPMS]#
Comment 1 Alexander Larsson 2003-09-05 10:33:14 EDT
fixed in 2.3.1-3
Comment 2 Chris Ricker 2003-09-05 16:12:35 EDT
*** Bug 103838 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.