Bug 1038305 - [GSS] (6.3) Logging DUP leaking class loaders
Summary: [GSS] (6.3) Logging DUP leaking class loaders
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: TBD EAP 6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR0
: EAP 6.3.0
Assignee: James Perkins
QA Contact: Nikoleta Hlavickova
Russell Dickenson
URL:
Whiteboard:
: 1049138 (view as bug list)
Depends On:
Blocks: 1049074
TreeView+ depends on / blocked
 
Reported: 2013-12-04 21:11 UTC by James Perkins
Modified: 2014-06-28 15:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1049074 (view as bug list)
Environment:
Last Closed: 2014-06-28 15:40:01 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker WFLY-2595 0 Critical Resolved Logging DUP leaking class loaders 2017-03-16 11:43:37 UTC

Internal Links: 1049074

Description James Perkins 2013-12-04 21:11:40 UTC
When per-deployment logging or logging-profiles are used on a deployment the undeploy is not removing the class loaders from the LogContextSelector.

The error appeared when the switch was made to use the ClassLoaderLogContextSelector which uses the call stack to determine the LogContext. The commit hash is 526c2ae7a4194dc6b787c32c5218cea003276900 that introduced the error.

The bug appears in 6.1.x and 6.2.x.

Comment 2 James Perkins 2014-01-07 19:21:42 UTC
*** Bug 1049138 has been marked as a duplicate of this bug. ***

Comment 4 Nikoleta Hlavickova 2014-02-24 13:15:09 UTC
Verified with EAP 6.3.0 DR0


Note You need to log in before you can comment on or make changes to this bug.