Bug 1049138 - Redeploy of a WAR results in ClassLoader leak when a logging-profile is enabled
Summary: Redeploy of a WAR results in ClassLoader leak when a logging-profile is enabled
Keywords:
Status: CLOSED DUPLICATE of bug 1038305
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: James Perkins
QA Contact: Nikoleta Hlavickova
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 05:25 UTC by Osamu Nagano
Modified: 2018-12-04 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-07 19:21:42 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker LOGMGR-90 0 Major Closed Redeploy of a WAR results in ClassLoader leak when a logging-profile is enabled 2018-12-05 00:21:21 UTC

Description Osamu Nagano 2014-01-07 05:25:47 UTC
Description of problem:
Web app's ModuleClassLoader is not released even after its undeployment. It seems contextMap of org.jboss.logmanager.ClassLoaderLogContextSelector object is holding the class loader's reference. If no logging-profile is configured, it doesn't leak.

Version-Release number of selected component (if applicable):
JBoss LogManager 1.4.0.Final (EAP 6.1.0) and 1.5.1.Final (EAP 6.2.0) as well.

Steps to Reproduce:
See LOGMGR-90.

Comment 1 Osamu Nagano 2014-01-07 05:30:40 UTC
contextMap is an object of CopyOnWriteMap.  I changed it to CopyOnWriteWeakMap but it didn't help.

Comment 2 James Perkins 2014-01-07 05:33:48 UTC
I was just working on this as part of https://bugzilla.redhat.com/show_bug.cgi?id=1038305. I just sent a PR for it.

Comment 3 Osamu Nagano 2014-01-07 05:47:40 UTC
Oh, I'm not aware of it.  I'll test the fix tomorrow.  Thanks.

Comment 4 James Perkins 2014-01-07 19:21:42 UTC
Closing as duplicate.

*** This bug has been marked as a duplicate of bug 1038305 ***


Note You need to log in before you can comment on or make changes to this bug.