Bug 103852 - installing with --root is still broken
installing with --root is still broken
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
GinGin64
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
: 106057 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 14:29 EDT by Michael Schröder
Modified: 2007-04-18 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-05 06:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that fixes it (hopefully) (1.78 KB, patch)
2003-09-05 14:30 EDT, Michael Schröder
no flags Details | Diff

  None (edit)
Description Michael Schröder 2003-09-05 14:29:01 EDT
I already sent you a fix that tries to fix installation with --root by
calling rpmdbOpenAll() before the chroot(). It turned out that this also
leads to problems, as the temporary databases are opened as well. If Berkeley
db runs out of memory it tries to open a backing store for the temporary
files and fails.
I fixed this by adding another function, rpmdbOpenAllButTemporary().
Comment 1 Michael Schröder 2003-09-05 14:30:00 EDT
Created attachment 94250 [details]
patch that fixes it (hopefully)
Comment 2 Leonard den Ottolander 2004-03-10 09:50:22 EST
I have no problems using --root on FC 1. I did a full installation
using --root (and --aid) to an nfs mounted system.

What exactly is the problem you are seeing? Do you still experience
it? What is your fix supposed to accomplish?

What version of rpm are you talking about? Is this architecture specific?
Comment 3 Jeff Johnson 2006-08-05 06:43:25 EDT
I've modified rpmdbOpenAll() to not open RPMDBI_DEPENDS.

Meanwhile, I don't believe that calling rpmdbOpenAll() before chroot entry is
the correct fix, because (potentially) there may be many more indices than
currently exist somewhen, and because I believe the better fix is to understand
why Berkeley DB re-opens db files on close to check cache coherency, not by
opening all possible database files.

I'm certainly willing to make the behavior run-time configurable, with default to not
call rpmdbOpenAll, if you (or someone) wish to send a patch.

Fixed in rpm cvs, will be in rpm-4.4.7 when released.
Comment 4 Jeff Johnson 2006-08-05 07:13:11 EDT
*** Bug 106057 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.