Bug 1038893 - backintime-kde-root wants kdesudo which is no longer in Fedora
Summary: backintime-kde-root wants kdesudo which is no longer in Fedora
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: backintime
Version: 19
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-06 04:54 UTC by J. Randall Owens
Modified: 2013-12-31 02:02 UTC (History)
3 users (show)

Fixed In Version: backintime-1.0.34-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-28 02:04:10 UTC


Attachments (Terms of Use)

Description J. Randall Owens 2013-12-06 04:54:53 UTC
Description of problem:
In /usr/share/applications/kde4/backintime-kde4-root.desktop, "Exec=kdesudo -c backintime-kde4-root". But while I remember using kdesudo a while ago (or that might have been kdesu), it certainly isn't on my system now, and `yum search all kdesudo` comes up empty. If I'm wrong and it is out there somewhere, it should be Required by backintime-kde.

Version-Release number of selected component (if applicable):
1.0.28-2.fc19

How reproducible:
Should be quite consistent.

Steps to Reproduce:
1. yum install backintime-kde
2. From Kickoff launcher -> Applications -> Administration -> Back In Time

Actual results:
In ~/.xsession-errors, "Could not find 'kdesudo' executable."

Expected results:
Runs backintime-kde4-root or backintime-kde4 as root, after authentication of some kind.

Additional info:
For some reason, it does require usermode-gtk, even though it doesn't use that here.
Perhaps because when I run backintime-kde4-root as ordinary user, I do get a root authentication popup, and then it does run as root. So, it probably just needs the "kdesudo -c " part removed from the Exec line, and then should work as expected.
Using kdesu instead might be another option.
kdesudo is probably leftover cruft from (k)ubuntu, which does seem to have it, much like the default "~/Ubuntu One" which is still in the recommended excludes, and could go away.
May be indirectly related to Bug #502806, "switch to using PolicyKit".
On a tangent, it would be nice if the menu entries were more clearly labelled by default, so you can tell root from not-root version, and -kde4 from -gnome. The Gnome one in the Administration menu is at least labelled "Back In Time (root)", so I can tell it from the KDE one there. When you get to it by typing "backintime" in the Kickoff search, there's no way of knowing which is which between root and non-root.

Comment 1 germar.reitze 2013-12-07 17:06:38 UTC
@Christopher you can use 'kde4/configure --kdesu' to change kdesudo to kdesu before packaging.
Regards,
Germar

Comment 2 Christopher Meng 2013-12-14 09:49:46 UTC
Yes, I've noticed this problem when updating 1.0.28, I will push an update soon.

Comment 3 Fedora Update System 2013-12-22 04:00:49 UTC
backintime-1.0.34-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/backintime-1.0.34-1.fc19

Comment 4 Fedora Update System 2013-12-22 04:01:02 UTC
backintime-1.0.34-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/backintime-1.0.34-1.fc20

Comment 5 Fedora Update System 2013-12-23 03:44:26 UTC
Package backintime-1.0.34-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing backintime-1.0.34-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23860/backintime-1.0.34-1.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Admin XMLRPC Client 2013-12-24 00:48:44 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Fedora Update System 2013-12-28 02:04:10 UTC
backintime-1.0.34-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-12-31 02:02:21 UTC
backintime-1.0.34-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.