Bug 103898 - Evolution crashes when adding a new word to spell check database
Evolution crashes when adding a new word to spell check database
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-06 16:20 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 15:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2003-09-06 16:20:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030720

Description of problem:
Evolution crashes when I select Add new word to Dictionary after right clicking
in a composing window.

Version-Release number of selected component (if applicable):
evolution-1.4.4-5

How reproducible:
Always

Steps to Reproduce:
1. Open Evolution
2. Click New to open a compose window
3. Type word like rsync in the body of the message
4. Right click on it and select Add new word to Dictionary
    

Actual Results:  Crash

Expected Results:  No Crash

Additional info:
Comment 1 Nathan G. Grennan 2003-09-06 16:25:35 EDT
Tried moving .aspell.en.prepl and .aspell.en.pws out of ~/, and it still crashed.
Comment 2 Jeremy Katz 2003-09-08 15:48:59 EDT
This works for me.  What language are you using?  Also, can you get a backtrace
of when it crashes?
Comment 3 Nathan G. Grennan 2003-09-08 21:59:16 EDT
Point me to some debug-info and I will give you a traceback.
Comment 5 Nathan G. Grennan 2003-09-13 18:57:20 EDT
#0  0x40ea9127 in g_str_hash () from /usr/lib/libglib-2.0.so.0
#1  0x40e8a498 in g_hash_table_lookup () from /usr/lib/libglib-2.0.so.0
#2  0x44ac5bcb in gnome_spell_control_new ()
   from /usr/lib/gnome-spell/libgnome-spell-component-0.3.so
#3  0x4148fd6a in _ORBIT_skel_small_GNOME_Spell_Dictionary_addWordToPersonal
(_o_servant=0x0,
    _o_retval=0x0, _o_args=0x89cbed0, _o_ctx=0x0, _o_ev=0x0,
    _impl_addWordToPersonal=0x44ac5b70 <gnome_spell_control_new+3872>) at
Spell-common.c:89
#4  0x404e393d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#5  0x4149051c in GNOME_Spell_Dictionary_addWordToPersonal (_obj=0x0,
word=0x8a119c8 "cygnus",
    language=0x0, ev=0x0) at Spell-stubs.c:110
#6  0x44ab142e in spell_add_to_personal () from
/usr/lib/gtkhtml/libgnome-gtkhtml-editor-3.0.so
#7  0x44aac26e in gtk_html_persist_stream_new ()
   from /usr/lib/gtkhtml/libgnome-gtkhtml-editor-3.0.so
#8  0x40e53051 in g_cclosure_marshal_VOID__VOID () from /usr/lib/libgobject-2.0.so.0
#9  0x40e40cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#10 0x40e52bbf in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#11 0x40e51c36 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Comment 6 Nathan G. Grennan 2003-10-04 15:51:12 EDT
I haven't seen this after doing some upgrades.

Note You need to log in before you can comment on or make changes to this bug.