Bug 103900 - Panel no longer respects mimimized size gconf setting
Panel no longer respects mimimized size gconf setting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-panel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-06 16:35 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 12:36:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2003-09-06 16:35:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030720

Description of problem:
The Gnome panel no longer respects the apps/panel/global/panel_minimized_size
gconf setting. The default before was three and I have always changed it to 0. I
hide my panel and I maximize Evolution, Galeon, Konqueror, and Pan. I don't like
the panel hiding the status bar of such applications.

Version-Release number of selected component (if applicable):
gnome-panel-2.3.90-1

How reproducible:
Always

Steps to Reproduce:
1. Hide panel
2. Change apps/panel/global/panel_minimized_size to various values


Actual Results:  No change in the panel size when hidden

Expected Results:  Change in the panel size when hidden

Additional info:

This worked fine with previous versions in Shrike and Severn, aka Gnome 2.2.
Comment 1 Havoc Pennington 2003-09-06 17:19:09 EDT
This needs to be reported/addressed on the bugzilla.gnome.org level, 
since we don't like to fork config option names/semantics or APIs.
(And the issue doesn't merit maintaining a long-term patch 
distinct from upstream anyhow.)

I periodically file all bugs with MoveUpstream keyword on gnome.org, 
if you do it yourself please add a link to the gnome bug here
and resolve as UPSTREAM.
Comment 2 Leonard den Ottolander 2004-02-23 05:50:49 EST
Closely related to bug 112469. I'll see if I can find an upstream
tracking number.
Comment 3 Leonard den Ottolander 2004-02-26 09:16:44 EST
Fixed with gnome-panel-2.4.2-1. Setting
/apps/panel/profiles/default/toplevels/bottom_panel now works as
expected (minimum size is 1 pixel).

Can be closed ERRATA as soon as the update makes it to the main tree.
Comment 4 Mark McLoughlin 2004-02-27 12:36:05 EST
Yeah, the key you want is
/apps/panel/profiles/default/toplevels/$(panel)/auto_hide_size

This should work with gnome-panel-2.4.0 too

Note You need to log in before you can comment on or make changes to this bug.