Bug 103908 - redhat-control-network doesn't start because of permissions
redhat-control-network doesn't start because of permissions
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-06 23:30 EDT by Santiago Erquicia
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-28 08:55:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Erquicia 2003-09-06 23:30:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When I try to start it as a normal user, there are 3 messages that say:

redhat-config-network:

Error copying 
//etc/hosts
to //etc/sysconfig/networking/profiles//default/hosts:
[Errno 13] Permission denied: '//etc/sysconfig/networking/profiles//default/hosts'!

redhat-config-network:

Error copying 
//etc/resolv.conf
to //etc/sysconfig/networking/profiles//default/resolv.conf:
[Errno 13] Permission denied:
'//etc/sysconfig/networking/profiles//default/resolv.conf'!

redhat-config-network:

Please start redhat-config-network with root permissions once!

If I start it as root, everything starts fine.

The launcher doesn't ask for a root password when is executed by a normal user.

After I run it as root, the same errors keep appearing but at least it shows the
network interfaces.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Menu - System Tools - Network Device Control as a normal user
2.
3.
    

Additional info:
Comment 1 Harald Hoyer 2003-09-08 05:11:22 EDT
redhat-control-network or redhat-config-network ???
If you start redhat-control-network as a normal user, it should display all
interfaces it can read...
redhat-config-network should be run as root in every case...
Comment 2 Santiago Erquicia 2003-09-08 10:17:19 EDT
The problem is in redhat-control-network as a normal user.

Someone at the mailing list asked me if I had /usr/sbin in my path.  I don't
have /usr/sbin at all in my path

here is what prints printenv

PATH=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/santiago/bin

I tried to put /usr/sbin in my path and everything is fine.

I'm not running it right now, so please tell me if you need more info

Note You need to log in before you can comment on or make changes to this bug.