Bug 103926 - Monitor information breaks redhat-config-xfree86
Monitor information breaks redhat-config-xfree86
Status: CLOSED WORKSFORME
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-07 15:51 EDT by Dirk Nehring
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-05 13:00:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
replacement monitor.py with some debug messages added (12.04 KB, text/plain)
2004-03-05 11:42 EST, Brent Fox
no flags Details

  None (edit)
Description Dirk Nehring 2003-09-07 15:51:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I have a monitor which identifies itself as '19" Monitor'. Since a double quote 
is used for the options in XF86Config, the additional double quote breaks 
redhat-config-xfree86. This is a long-standing but which is fixed until now.

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.9.6-1

How reproducible:
Always

Steps to Reproduce:
1. Buy an monitor which has the internal DPMS name 19" monitor
2. delete /etc/X11/XF86Config
3. run 'redhat-config-xfree86'

Additional info:
Comment 1 Jason Tibbitts 2003-09-08 17:30:57 EDT
I'm having exactly the same problem; I just purchased a pallet of cheap 17" LCD
monitors from Daewoo which identify themselves uselessly as:

17" TFT

Resulting in the error:

Parse error on line 91 of section Monitor in file /etc/X11/XF86Config
        "TFT"" is not a valid keyword in this section.

Taking out the extra quote manually results in a working config file.
Comment 2 Brent Fox 2003-10-15 16:54:22 EDT
Hmm, this looks like a dupe of bug #87588, which was fixed long ago but seems to
have returned.  I can't figure out how, though, since the code is still there in
monitor.py from rhpl.

What version of rhpl are you running?
Comment 3 Dirk Nehring 2003-10-16 17:34:40 EDT
It's the version from Fedora beta1: rhpl-0.113-1
Comment 4 Brent Fox 2004-03-05 11:42:32 EST
Created attachment 98323 [details]
replacement monitor.py with some debug messages added

I can't really see how this bug can still be happening since the code has been
there for almost a year that strips out all " chars from the probed return
value.

Use this monitor.py to replace your
/usr/lib/python2.2/site-packages/rhpl/monitor.py file.	I have added some debug
messages to try to figure out what is happening.

Then run redhat-config-xfree86 from a command line and paste all the debug
messages to this bug report.
Comment 5 Brent Fox 2004-03-05 11:44:30 EST
Also, it would be helpful if both of you could run (as root)
'/usr/sbin/ddcprobe' and paste the output here too.

Comment 6 Dirk Nehring 2004-03-05 11:50:40 EST
Since I do not have this monitor any more (now I have a 19" digital 
TFT one :-))), I cannot do this anymore. Sorry.
Comment 7 Brent Fox 2004-03-05 13:00:31 EST
Ok, well, since Dirk is the original bug reporter, I'm going to close
this bug.  Jason, please reopen this report if you can perform the
tests I recommended above.

Note You need to log in before you can comment on or make changes to this bug.